aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortex-a9.mk
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-03-28 18:07:09 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-04-06 16:31:10 +0200
commit2e5a0b81ec29a897fde5ca30b0dc95fd28b9d4fb (patch)
treeebbe1bb79a6e3aafa178df77f6588c2edad2aaea /target/linux/mvebu/image/cortex-a9.mk
parent4e8345ff68f56e10167c2b7c9109d844c77053bd (diff)
downloadupstream-2e5a0b81ec29a897fde5ca30b0dc95fd28b9d4fb.tar.gz
upstream-2e5a0b81ec29a897fde5ca30b0dc95fd28b9d4fb.tar.bz2
upstream-2e5a0b81ec29a897fde5ca30b0dc95fd28b9d4fb.zip
mvebu: sysupgrade: sdcard: keep user added partitons
Currently sysupgrade overwrites whole disk and destroys partitions added by user. Sync the sysupgrade code with the one present in x86 target to remedy this behaviour. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/mvebu/image/cortex-a9.mk')
-rw-r--r--target/linux/mvebu/image/cortex-a9.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/target/linux/mvebu/image/cortex-a9.mk b/target/linux/mvebu/image/cortex-a9.mk
index 9d84283525..66cf54f9c5 100644
--- a/target/linux/mvebu/image/cortex-a9.mk
+++ b/target/linux/mvebu/image/cortex-a9.mk
@@ -126,7 +126,7 @@ define Device/armada-388-clearfog-pro
KERNEL_INSTALL := 1
KERNEL := kernel-bin
DEVICE_TITLE := SolidRun ClearFog Pro
- DEVICE_PACKAGES := mkf2fs e2fsprogs swconfig
+ DEVICE_PACKAGES := mkf2fs e2fsprogs partx-utils swconfig
IMAGES := sdcard.img.gz
IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
DEVICE_DTS := armada-388-clearfog-pro armada-388-clearfog-base
@@ -139,7 +139,7 @@ define Device/armada-388-clearfog-base
KERNEL_INSTALL := 1
KERNEL := kernel-bin
DEVICE_TITLE := SolidRun ClearFog Base
- DEVICE_PACKAGES := mkf2fs e2fsprogs
+ DEVICE_PACKAGES := mkf2fs e2fsprogs partx-utils
IMAGES := sdcard.img.gz
IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
DEVICE_DTS := armada-388-clearfog-pro armada-388-clearfog-base
@@ -162,7 +162,8 @@ define Device/turris-omnia
DEVICE_TITLE := Turris Omnia
DEVICE_PACKAGES := \
mkf2fs e2fsprogs kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
- wpad-basic kmod-ath9k kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ wpad-basic kmod-ath9k kmod-ath10k-ct ath10k-firmware-qca988x-ct \
+ partx-utils
IMAGES := $$(IMAGE_PREFIX)-sysupgrade.img.gz omnia-medkit-$$(IMAGE_PREFIX)-initramfs.tar.gz
IMAGE/$$(IMAGE_PREFIX)-sysupgrade.img.gz := boot-img | sdcard-img | gzip | append-metadata
IMAGE/omnia-medkit-$$(IMAGE_PREFIX)-initramfs.tar.gz := omnia-medkit-initramfs | gzip