aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortex-a53.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-18 02:21:12 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-21 14:23:52 +0100
commite93626f1f47ec6c1995067c9ed3798ebd468cda3 (patch)
treea35e4f9be1d413ff567062820589c8248f401879 /target/linux/mvebu/image/cortex-a53.mk
parent0a388b5bf7b5dbc60df94594c77d932bdd95cba6 (diff)
downloadupstream-e93626f1f47ec6c1995067c9ed3798ebd468cda3.tar.gz
upstream-e93626f1f47ec6c1995067c9ed3798ebd468cda3.tar.bz2
upstream-e93626f1f47ec6c1995067c9ed3798ebd468cda3.zip
mvebu: use SOC to derive DEVICE_DTS
This introduces the SOC variable to mvebu target to derive some of the DEVICE_DTS variables based on the SOC prefix and the device definition name. Since DTS names and compatible are inconsistent also in the kernel for this target, the scheme cannot be applied to all devices, though. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Acked-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/mvebu/image/cortex-a53.mk')
-rw-r--r--target/linux/mvebu/image/cortex-a53.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/mvebu/image/cortex-a53.mk b/target/linux/mvebu/image/cortex-a53.mk
index e58a3c42b9..73bd61f22e 100644
--- a/target/linux/mvebu/image/cortex-a53.mk
+++ b/target/linux/mvebu/image/cortex-a53.mk
@@ -6,7 +6,7 @@ define Device/globalscale_espressobin
DEVICE_ALT0_VENDOR := Marvell
DEVICE_ALT0_MODEL := Armada 3700 Community Board
DEVICE_ALT0_VARIANT := Non-eMMC
- DEVICE_DTS := armada-3720-espressobin
+ SOC := armada-3720
endef
TARGET_DEVICES += globalscale_espressobin
@@ -18,7 +18,7 @@ define Device/globalscale_espressobin-emmc
DEVICE_ALT0_VENDOR := Marvell
DEVICE_ALT0_MODEL := Armada 3700 Community Board
DEVICE_ALT0_VARIANT := eMMC
- DEVICE_DTS := armada-3720-espressobin-emmc
+ SOC := armada-3720
endef
TARGET_DEVICES += globalscale_espressobin-emmc
@@ -30,7 +30,7 @@ define Device/globalscale_espressobin-v7
DEVICE_ALT0_VENDOR := Marvell
DEVICE_ALT0_MODEL := Armada 3700 Community Board
DEVICE_ALT0_VARIANT := V7 Non-eMMC
- DEVICE_DTS := armada-3720-espressobin-v7
+ SOC := armada-3720
endef
TARGET_DEVICES += globalscale_espressobin-v7
@@ -42,7 +42,7 @@ define Device/globalscale_espressobin-v7-emmc
DEVICE_ALT0_VENDOR := Marvell
DEVICE_ALT0_MODEL := Armada 3700 Community Board
DEVICE_ALT0_VARIANT := V7 eMMC
- DEVICE_DTS := armada-3720-espressobin-v7-emmc
+ SOC := armada-3720
endef
TARGET_DEVICES += globalscale_espressobin-v7-emmc