aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortex-a53.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-18 02:21:11 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-21 14:18:07 +0100
commit0a388b5bf7b5dbc60df94594c77d932bdd95cba6 (patch)
treeca8b22af59a20a90289901cbe41cbb491141b549 /target/linux/mvebu/image/cortex-a53.mk
parentb99b60b2f164cb62212dd9812ddc8ce8df9f90a9 (diff)
downloadupstream-0a388b5bf7b5dbc60df94594c77d932bdd95cba6.tar.gz
upstream-0a388b5bf7b5dbc60df94594c77d932bdd95cba6.tar.bz2
upstream-0a388b5bf7b5dbc60df94594c77d932bdd95cba6.zip
mvebu: move subtarget image Makefile switch to parent Makefile
This moves the if conditions for choosing which image Makefiles are used to the parent image/Makefile. It seems more convenient to have "codeflow" in the parent while the subtarget-specific files only contain the definitions. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Acked-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/mvebu/image/cortex-a53.mk')
-rw-r--r--target/linux/mvebu/image/cortex-a53.mk4
1 files changed, 0 insertions, 4 deletions
diff --git a/target/linux/mvebu/image/cortex-a53.mk b/target/linux/mvebu/image/cortex-a53.mk
index f5313429af..e58a3c42b9 100644
--- a/target/linux/mvebu/image/cortex-a53.mk
+++ b/target/linux/mvebu/image/cortex-a53.mk
@@ -1,5 +1,3 @@
-ifeq ($(SUBTARGET),cortexa53)
-
define Device/globalscale_espressobin
$(call Device/Default-arm64)
DEVICE_VENDOR := Marvell
@@ -73,5 +71,3 @@ define Device/methode_udpu
BOOT_SCRIPT := udpu
endef
TARGET_DEVICES += methode_udpu
-
-endif