aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/Makefile
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-05-11 19:37:31 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-11 23:11:04 +0200
commit9509a6df0bff483fc165bc5da98f03d2d736622f (patch)
tree8169106db4cc27a76d32ffe58f7e99b974d4b750 /target/linux/mvebu/image/Makefile
parentfb005d688ea2955df89279d75499fca26e2f6f00 (diff)
downloadupstream-9509a6df0bff483fc165bc5da98f03d2d736622f.tar.gz
upstream-9509a6df0bff483fc165bc5da98f03d2d736622f.tar.bz2
upstream-9509a6df0bff483fc165bc5da98f03d2d736622f.zip
mvebu: image: improve readability of device recipes
Drop overly complex amount of defines wich are referenced in the same devices pool and move image recipes to common define, since devices not using them overwrite it. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/mvebu/image/Makefile')
-rw-r--r--target/linux/mvebu/image/Makefile21
1 files changed, 5 insertions, 16 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 95d4d5a79b..108b569c07 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -80,7 +80,11 @@ define Device/Default
BOARD_NAME = $$(DEVICE_DTS)
KERNEL_NAME := zImage
KERNEL := kernel-bin | append-dtb | uImage none
- SUPPORTED_DEVICES = $$(DEVICE_DTS)
+ IMAGES := sysupgrade.bin
+ IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | pad-to $$$$(PAGESIZE)
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+ SUPPORTED_DEVICES = $$(firstword $$(DEVICE_DTS))
+ UBINIZE_OPTS := -E 5
UBOOT :=
BOOT_SCRIPT :=
endef
@@ -95,20 +99,7 @@ define Device/Default-arm64
KERNEL := kernel-bin
endef
-define Device/UBI
- IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
-endef
-
-define Device/UBI-factory
- $(Device/UBI)
- UBINIZE_OPTS := -E 5
- IMAGES += factory.img
- IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | pad-to $$$$(PAGESIZE)
-endef
-
define Device/NAND-128K
- $(Device/UBI)
BLOCKSIZE := 128k
PAGESIZE := 2048
SUBPAGESIZE := 512
@@ -116,13 +107,11 @@ define Device/NAND-128K
endef
define Device/NAND-256K
- $(Device/UBI)
BLOCKSIZE := 256k
PAGESIZE := 4096
endef
define Device/NAND-512K
- $(Device/UBI)
BLOCKSIZE := 512k
PAGESIZE := 4096
endef