aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/Makefile
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-05-11 19:37:34 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-11 23:11:04 +0200
commitee96fa15b1866d802a9a74dba2d6b1f81084e5f1 (patch)
tree1c7d2e64a149699b7923f26fcd1e6ff35c820a46 /target/linux/mvebu/image/Makefile
parenta39d2a8053a656f75ffdd914d433e33fef86ee3e (diff)
downloadupstream-ee96fa15b1866d802a9a74dba2d6b1f81084e5f1.tar.gz
upstream-ee96fa15b1866d802a9a74dba2d6b1f81084e5f1.tar.bz2
upstream-ee96fa15b1866d802a9a74dba2d6b1f81084e5f1.zip
mvebu: use device-tree board detection
Convert whole target to Device Tree based board detection instead of identifying devices by dts file name. With this we can drop mvebu.sh translation script and rely on common method for model detection. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/mvebu/image/Makefile')
-rw-r--r--target/linux/mvebu/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index f432a37911..57e5a30491 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -76,7 +76,7 @@ define Device/Default
IMAGES := sysupgrade.bin
IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | pad-to $$$$(PAGESIZE)
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
- SUPPORTED_DEVICES = $$(firstword $$(DEVICE_DTS))
+ SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
UBINIZE_OPTS := -E 5
UBOOT :=
BOOT_SCRIPT :=