aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/Makefile
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2019-11-04 10:55:23 -1000
committerPetr Štetiar <ynezz@true.cz>2019-11-11 16:37:13 +0100
commite97113d5e18c31050bc06f7c6b7a5c663b5f31a4 (patch)
tree23ae74bd5c272deec16f973bd5208689550d42c7 /target/linux/mvebu/image/Makefile
parent98d1c7d83485ed2b024bf8ab5f8ff7e2a66ab85e (diff)
downloadupstream-e97113d5e18c31050bc06f7c6b7a5c663b5f31a4.tar.gz
upstream-e97113d5e18c31050bc06f7c6b7a5c663b5f31a4.tar.bz2
upstream-e97113d5e18c31050bc06f7c6b7a5c663b5f31a4.zip
x86,tegra,mvebu: image: use common reproducible IMG_PART_SIGNATURE
These targets are currently using more or less same SIGNATURE variable which provides unique partition ID/signature, so it makes sense to refactor it out into common IMG_PART_SIGNATURE variable which could be reused by all targets. This is another step in the direction of reproducible OpenWrt images. Signed-off-by: Paul Spooren <mail@aparcar.org> [split into separate commit, renamed to IMG_PART_SIGNATURE] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/mvebu/image/Makefile')
-rw-r--r--target/linux/mvebu/image/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 967a1e4ee1..ce1344a547 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -13,12 +13,10 @@ include $(INCLUDE_DIR)/image.mk
KERNEL_LOADADDR := 0x00008000
-SIGNATURE:=$(shell printf "%.8s" $(SOURCE_DATE_EPOCH))
-
define Build/boot-scr
rm -f $@-boot.scr
sed \
- -e 's#@ROOT@#$(SIGNATURE)#g' \
+ -e 's#@ROOT@#$(IMG_PART_SIGNATURE)#g' \
-e 's#@DTB@#$(firstword $(DEVICE_DTS))#g' \
$(BOOT_SCRIPT).bootscript > $@-new.bootscript
mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d $@-new.bootscript $@-boot.scr
@@ -42,7 +40,7 @@ define Build/boot-img-ext4
endef
define Build/sdcard-img
- SIGNATURE="$(SIGNATURE)" \
+ SIGNATURE="$(IMG_PART_SIGNATURE)" \
./gen_mvebu_sdcard_img.sh $@ \
$(if $(UBOOT),$(STAGING_DIR_IMAGE)/$(UBOOT)) \
c $(CONFIG_TARGET_KERNEL_PARTSIZE) $@.boot \
@@ -50,7 +48,7 @@ define Build/sdcard-img
endef
define Build/sdcard-img-ext4
- SIGNATURE="$(SIGNATURE)" \
+ SIGNATURE="$(IMG_PART_SIGNATURE)" \
./gen_mvebu_sdcard_img.sh $@ \
$(if $(UBOOT),$(STAGING_DIR_IMAGE)/$(UBOOT)) \
83 $(CONFIG_TARGET_KERNEL_PARTSIZE) $@.bootimg \