aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-01-08 22:20:16 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-01-08 22:20:16 +0000
commit25475a095ec71f55826a5864e78e09c27031f179 (patch)
treeb2926b2267a4d1075ba4f6b2dd381aad8fca6518 /target/linux/mvebu/Makefile
parent97acd10458aa9bd57fc5ddd936891a59c80bce3e (diff)
downloadupstream-25475a095ec71f55826a5864e78e09c27031f179.tar.gz
upstream-25475a095ec71f55826a5864e78e09c27031f179.tar.bz2
upstream-25475a095ec71f55826a5864e78e09c27031f179.zip
mvebu: add inital support for Marvell Armada XP/370 SoCs
This brings in the initial support for the Marvell Armada XP/370 SoCs. Successfully tested on RD-A370-A1 and DB-MV784MP-GP boards the following interfaces: - Ethernet - SDIO - GPIOs - SATA Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 35058
Diffstat (limited to 'target/linux/mvebu/Makefile')
-rw-r--r--target/linux/mvebu/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/mvebu/Makefile b/target/linux/mvebu/Makefile
new file mode 100644
index 0000000000..4ff5fe20a1
--- /dev/null
+++ b/target/linux/mvebu/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=mvebu
+BOARDNAME:=Marvell Armada XP/370 boards
+FEATURES:=targz usb jffs2 pci pcie gpio
+CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+
+LINUX_VERSION:=3.8-rc2
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="zImage dtbs"
+
+DEFAULT_PACKAGES +=
+
+$(eval $(call BuildTarget))