aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/patches-5.4/106-powerpc-85xx-ws-ap3710i-support.patch
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-02-24 22:49:45 +0100
committerDavid Bauer <mail@david-bauer.net>2020-02-28 23:32:37 +0100
commit1287bb48dc7295b56d4597a3789429da618a8ec7 (patch)
tree87e983202ee8af1c17e47e276dc9092eaa2a2290 /target/linux/mpc85xx/patches-5.4/106-powerpc-85xx-ws-ap3710i-support.patch
parenta2ae9a07d2d4843665d04ddcc1357ee22a72216a (diff)
downloadupstream-1287bb48dc7295b56d4597a3789429da618a8ec7.tar.gz
upstream-1287bb48dc7295b56d4597a3789429da618a8ec7.tar.bz2
upstream-1287bb48dc7295b56d4597a3789429da618a8ec7.zip
mpc85xx: fix build with kernel 5.4
This fixes some outstanding issues with the Kernel 5.4 build: * Adds missing support patch for the Enterasys WS-AP3710i * Fixes incorrect NAND symbols * Adds patch for broken image wrapping Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/mpc85xx/patches-5.4/106-powerpc-85xx-ws-ap3710i-support.patch')
-rw-r--r--target/linux/mpc85xx/patches-5.4/106-powerpc-85xx-ws-ap3710i-support.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/patches-5.4/106-powerpc-85xx-ws-ap3710i-support.patch b/target/linux/mpc85xx/patches-5.4/106-powerpc-85xx-ws-ap3710i-support.patch
new file mode 100644
index 0000000000..4bacedbcd7
--- /dev/null
+++ b/target/linux/mpc85xx/patches-5.4/106-powerpc-85xx-ws-ap3710i-support.patch
@@ -0,0 +1,30 @@
+--- a/arch/powerpc/platforms/85xx/Kconfig
++++ b/arch/powerpc/platforms/85xx/Kconfig
+@@ -71,6 +71,17 @@ config PANDA
+ This board is a Concurrent Dual-Band wireless access point with a
+ Freescale P1020 SoC.
+
++config WS_AP3710I
++ bool "Enterasys WS-AP3710i"
++ select DEFAULT_UIMAGE
++ select ARCH_REQUIRE_GPIOLIB
++ select GPIO_MPC8XXX
++ help
++ This option enables support for the Enterasys WS-AP3710i board.
++
++ This board is a Concurrent Dual-Band wireless access point with a
++ Freescale P1020 SoC.
++
+ config MPC8540_ADS
+ bool "Freescale MPC8540 ADS"
+ select DEFAULT_UIMAGE
+--- a/arch/powerpc/platforms/85xx/Makefile
++++ b/arch/powerpc/platforms/85xx/Makefile
+@@ -24,6 +24,7 @@ obj-$(CONFIG_P1022_RDK) += p1022_rdk.o
+ obj-$(CONFIG_P1023_RDB) += p1023_rdb.o
+ obj-$(CONFIG_PANDA) += panda.o
+ obj-$(CONFIG_TWR_P102x) += twr_p102x.o
++obj-$(CONFIG_WS_AP3710I) += ws-ap3710i.o
+ obj-$(CONFIG_CORENET_GENERIC) += corenet_generic.o
+ obj-$(CONFIG_FB_FSL_DIU) += t1042rdb_diu.o
+ obj-$(CONFIG_RED_15W_REV1) += red15w_rev1.o