aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/patches-5.15/900-powerpc-bootwrapper-disable-uImage-generation.patch
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2023-04-12 10:43:43 +0200
committerChristian Lamparter <chunkeey@gmail.com>2023-05-14 00:08:35 +0200
commit95d5a99537a587103976120de0b0ba4d27e07d62 (patch)
tree5a350e425fe9b5e16f117356425d4fa2fef6de5f /target/linux/mpc85xx/patches-5.15/900-powerpc-bootwrapper-disable-uImage-generation.patch
parent749237967a122a40465b65c7e9eb6924d8fe09c4 (diff)
downloadupstream-95d5a99537a587103976120de0b0ba4d27e07d62.tar.gz
upstream-95d5a99537a587103976120de0b0ba4d27e07d62.tar.bz2
upstream-95d5a99537a587103976120de0b0ba4d27e07d62.zip
mpc85xx: add support for Aerohive BR200-WP
The following adds the Aerohive BR200-WP router to OpenWrt under the mpc85xx/p1010 subtarget. Hardware: - SoC: Freescale P1011 - NOR: Intel JS28F512M29EWH 64MB - Memory: 2x Nanya NT5TU64M16GG-AC 128MB (Total of 256MB) - 2.4GHz WiFi: Atheros AR9390-AL1A - Eth1: Atheros AR8035-A PoE - 2x LEDs - 1x Button - PoE PSE Flashing: 1. Hook into UART (9600 baud) and enter U-Boot. You may need to enter a password of administrator or AhNf?d@ta06 if prompted. 2. Once in U-Boot, tftp boot the initramfs image: dhcp; setenv serverip 192.168.1.3; tftpboot 0x2004000 openwrt-mpc85xx-p1010-aerohive_br200-wp-initramfs-kernel.bin; bootm 0x2004000; 3. Once booted, scp over the sysupgrade file and sysupgrade the device to flash LEDE to the NOR. Note: MAC assigns are taken from stock firmware: Name MAC addr Mode State Chan(Width) VLAN Radio Hive SSID -------- -------------- -------- ----- ----------- ---- ---------- ---------- --------- Mgt0 08ea:44XX:XXc0 - U - 1 - hive0 - Eth0 08ea:44XX:XXc0 wan U - - - - - Eth1 08ea:44XX:XXc2 access D - - - hive0 - Eth2 08ea:44XX:XXc3 access D - - - hive0 - Eth3 08ea:44XX:XXc4 access D - - - hive0 - Eth4 08ea:44XX:XXc5 access D - - - hive0 - Wifi0 08ea:44XX:XXd0 access U 1(20MHz) - radio_ng0 - - Wifi0.1 08ea:44XX:XXd4 access D 1(20MHz) - radio_ng0 hive0 - Note2: PoE PSE could be managed with `realtek-poe` package. Example port config: config port option enable '1' option id '4' option name 'lan2' option poe_plus '0' option priority '2' config port option enable '1' option id '3' option name 'lan1' option poe_plus '0' option priority '1' Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com> (switch@0 -> switch@10, Device's quickstart says LEDs are amber and white => add function+color properties but keep labels around, use pr_info) Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/mpc85xx/patches-5.15/900-powerpc-bootwrapper-disable-uImage-generation.patch')
-rw-r--r--target/linux/mpc85xx/patches-5.15/900-powerpc-bootwrapper-disable-uImage-generation.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/mpc85xx/patches-5.15/900-powerpc-bootwrapper-disable-uImage-generation.patch b/target/linux/mpc85xx/patches-5.15/900-powerpc-bootwrapper-disable-uImage-generation.patch
index 66935c04b7..1af5aefe0b 100644
--- a/target/linux/mpc85xx/patches-5.15/900-powerpc-bootwrapper-disable-uImage-generation.patch
+++ b/target/linux/mpc85xx/patches-5.15/900-powerpc-bootwrapper-disable-uImage-generation.patch
@@ -16,7 +16,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
--- a/arch/powerpc/boot/Makefile
+++ b/arch/powerpc/boot/Makefile
-@@ -273,7 +273,6 @@ image-$(CONFIG_PPC_CHRP) += zImage.chrp
+@@ -274,7 +274,6 @@ image-$(CONFIG_PPC_CHRP) += zImage.chrp
image-$(CONFIG_PPC_EFIKA) += zImage.chrp
image-$(CONFIG_PPC_PMAC) += zImage.pmac
image-$(CONFIG_PPC_HOLLY) += dtbImage.holly
@@ -24,7 +24,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
image-$(CONFIG_EPAPR_BOOT) += zImage.epapr
#
-@@ -407,15 +406,6 @@ $(obj)/dtbImage.%: vmlinux $(wrapperbits
+@@ -409,15 +408,6 @@ $(obj)/dtbImage.%: vmlinux $(wrapperbits
$(obj)/vmlinux.strip: vmlinux
$(STRIP) -s -R .comment $< -o $@