aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/patches-5.15/105-powerpc-85xx-panda-support.patch
diff options
context:
space:
mode:
authorWojciech Dubowik <Wojciech.Dubowik@westermo.com>2022-09-14 12:12:06 +0200
committerPetr Štetiar <ynezz@true.cz>2022-09-14 16:45:06 +0200
commit00643b4584e73949de05ca8c3276a05657ba0d45 (patch)
treed531da4006fa7cb2b4c73290edcb4e7696bbee8d /target/linux/mpc85xx/patches-5.15/105-powerpc-85xx-panda-support.patch
parentdf59c07fe9e32bd5124871daa400a8c5e2e8d96f (diff)
downloadupstream-00643b4584e73949de05ca8c3276a05657ba0d45.tar.gz
upstream-00643b4584e73949de05ca8c3276a05657ba0d45.tar.bz2
upstream-00643b4584e73949de05ca8c3276a05657ba0d45.zip
mpc85xx: Copy over kernel 5.10 patches and config to 5.15
Split patches for better change visibility. Signed-off-by: Wojciech Dubowik <Wojciech.Dubowik@westermo.com> Signed-off-by: Petr Štetiar <ynezz@true.cz> [un-dmarc, commit description]
Diffstat (limited to 'target/linux/mpc85xx/patches-5.15/105-powerpc-85xx-panda-support.patch')
-rw-r--r--target/linux/mpc85xx/patches-5.15/105-powerpc-85xx-panda-support.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/patches-5.15/105-powerpc-85xx-panda-support.patch b/target/linux/mpc85xx/patches-5.15/105-powerpc-85xx-panda-support.patch
new file mode 100644
index 0000000000..4913c614a8
--- /dev/null
+++ b/target/linux/mpc85xx/patches-5.15/105-powerpc-85xx-panda-support.patch
@@ -0,0 +1,30 @@
+--- a/arch/powerpc/platforms/85xx/Kconfig
++++ b/arch/powerpc/platforms/85xx/Kconfig
+@@ -60,6 +60,17 @@ config HIVEAP_330
+ This board is a Concurrent Dual-Band wireless access point with a
+ Freescale P1020 SoC.
+
++config PANDA
++ bool "OCEDO PANDA"
++ select DEFAULT_UIMAGE
++ select ARCH_REQUIRE_GPIOLIB
++ select GPIO_MPC8XXX
++ help
++ This option enables support for the OCEDO PANDA board.
++
++ This board is a Concurrent Dual-Band wireless access point with a
++ Freescale P1020 SoC.
++
+ config MPC8540_ADS
+ bool "Freescale MPC8540 ADS"
+ select DEFAULT_UIMAGE
+--- a/arch/powerpc/platforms/85xx/Makefile
++++ b/arch/powerpc/platforms/85xx/Makefile
+@@ -24,6 +24,7 @@ obj-$(CONFIG_P1010_RDB) += p1010rdb.o
+ obj-$(CONFIG_P1022_DS) += p1022_ds.o
+ obj-$(CONFIG_P1022_RDK) += p1022_rdk.o
+ obj-$(CONFIG_P1023_RDB) += p1023_rdb.o
++obj-$(CONFIG_PANDA) += panda.o
+ obj-$(CONFIG_TWR_P102x) += twr_p102x.o
+ obj-$(CONFIG_CORENET_GENERIC) += corenet_generic.o
+ obj-$(CONFIG_FB_FSL_DIU) += t1042rdb_diu.o