aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/patches-5.15/101-powerpc-85xx-hiveap-330-support.patch
diff options
context:
space:
mode:
authorWojciech Dubowik <Wojciech.Dubowik@westermo.com>2022-09-14 12:12:06 +0200
committerPetr Štetiar <ynezz@true.cz>2022-09-14 16:45:06 +0200
commit00643b4584e73949de05ca8c3276a05657ba0d45 (patch)
treed531da4006fa7cb2b4c73290edcb4e7696bbee8d /target/linux/mpc85xx/patches-5.15/101-powerpc-85xx-hiveap-330-support.patch
parentdf59c07fe9e32bd5124871daa400a8c5e2e8d96f (diff)
downloadupstream-00643b4584e73949de05ca8c3276a05657ba0d45.tar.gz
upstream-00643b4584e73949de05ca8c3276a05657ba0d45.tar.bz2
upstream-00643b4584e73949de05ca8c3276a05657ba0d45.zip
mpc85xx: Copy over kernel 5.10 patches and config to 5.15
Split patches for better change visibility. Signed-off-by: Wojciech Dubowik <Wojciech.Dubowik@westermo.com> Signed-off-by: Petr Štetiar <ynezz@true.cz> [un-dmarc, commit description]
Diffstat (limited to 'target/linux/mpc85xx/patches-5.15/101-powerpc-85xx-hiveap-330-support.patch')
-rw-r--r--target/linux/mpc85xx/patches-5.15/101-powerpc-85xx-hiveap-330-support.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/patches-5.15/101-powerpc-85xx-hiveap-330-support.patch b/target/linux/mpc85xx/patches-5.15/101-powerpc-85xx-hiveap-330-support.patch
new file mode 100644
index 0000000000..da95cd2716
--- /dev/null
+++ b/target/linux/mpc85xx/patches-5.15/101-powerpc-85xx-hiveap-330-support.patch
@@ -0,0 +1,30 @@
+--- a/arch/powerpc/platforms/85xx/Kconfig
++++ b/arch/powerpc/platforms/85xx/Kconfig
+@@ -49,6 +49,17 @@ config BSC9132_QDS
+ and dual StarCore SC3850 DSP cores.
+ Manufacturer : Freescale Semiconductor, Inc
+
++config HIVEAP_330
++ bool "Aerohive HiveAP-330"
++ select DEFAULT_UIMAGE
++ select ARCH_REQUIRE_GPIOLIB
++ select GPIO_MPC8XXX
++ help
++ This option enables support for the Aerohive HiveAP-330 board.
++
++ This board is a Concurrent Dual-Band wireless access point with a
++ Freescale P1020 SoC.
++
+ config MPC8540_ADS
+ bool "Freescale MPC8540 ADS"
+ select DEFAULT_UIMAGE
+--- a/arch/powerpc/platforms/85xx/Makefile
++++ b/arch/powerpc/platforms/85xx/Makefile
+@@ -12,6 +12,7 @@ obj-y += common.o
+ obj-$(CONFIG_BSC9131_RDB) += bsc913x_rdb.o
+ obj-$(CONFIG_BSC9132_QDS) += bsc913x_qds.o
+ obj-$(CONFIG_C293_PCIE) += c293pcie.o
++obj-$(CONFIG_HIVEAP_330) += hiveap-330.o
+ obj-$(CONFIG_MPC8540_ADS) += mpc85xx_ads.o
+ obj-$(CONFIG_MPC8560_ADS) += mpc85xx_ads.o
+ obj-$(CONFIG_MPC85xx_CDS) += mpc85xx_cds.o