aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/patches-4.14
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2019-01-29 23:52:27 +0100
committerChristian Lamparter <chunkeey@gmail.com>2019-06-10 11:21:35 +0200
commit1e41de2f48e284c9d6658f9403365651178f6826 (patch)
tree90d34b3f3846e72374beb796576ade2951736274 /target/linux/mpc85xx/patches-4.14
parent452d88e8f798c550151cd1e1d204a528fb00db08 (diff)
downloadupstream-1e41de2f48e284c9d6658f9403365651178f6826.tar.gz
upstream-1e41de2f48e284c9d6658f9403365651178f6826.tar.bz2
upstream-1e41de2f48e284c9d6658f9403365651178f6826.zip
mpc85xx: convert TL-WDR4900 v1 to simpleImage
Converts the TP-Link WDR4900 v1 to use the simpleImage in the hopes of prolonging the life of the device. While at it, the patch makes the fdt.bin an ARTIFACT and sets the KERNEL_SIZE to 2684 KiB as a precaution since the stock u-boot is using a fixed kernel size. Note: Give the image some time, it will take much longer to extract and boot. [tested for 4.14/4.19] Signed-off-by: Christian Lamparter <chunkeey@gmail.com> Co-authored-by: Pawel Dembicki <paweldembicki@gmail.com> Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'target/linux/mpc85xx/patches-4.14')
-rw-r--r--target/linux/mpc85xx/patches-4.14/100-powerpc-85xx-tl-wdr4900-v1-support.patch54
1 files changed, 34 insertions, 20 deletions
diff --git a/target/linux/mpc85xx/patches-4.14/100-powerpc-85xx-tl-wdr4900-v1-support.patch b/target/linux/mpc85xx/patches-4.14/100-powerpc-85xx-tl-wdr4900-v1-support.patch
index 0fbb16f3bd..f74ed6fd8a 100644
--- a/target/linux/mpc85xx/patches-4.14/100-powerpc-85xx-tl-wdr4900-v1-support.patch
+++ b/target/linux/mpc85xx/patches-4.14/100-powerpc-85xx-tl-wdr4900-v1-support.patch
@@ -1,4 +1,4 @@
-From 406d86e5990ac171f18ef6e2973672d8fbfe1556 Mon Sep 17 00:00:00 2001
+From 53bc6ae5da3b2902581c30ac2568f51ce35e7624 Mon Sep 17 00:00:00 2001
From: Gabor Juhos <juhosg@openwrt.org>
Date: Wed, 20 Feb 2013 08:40:33 +0100
Subject: [PATCH] powerpc: 85xx: add support for the TP-Link TL-WDR4900 v1
@@ -9,44 +9,53 @@ concurrent dual-band wireless router. The devices uses
the Freescale P1014 SoC.
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
+Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
---
- arch/powerpc/boot/Makefile | 3 +
- arch/powerpc/boot/wrapper | 4 +
- arch/powerpc/platforms/85xx/Kconfig | 11 ++
- arch/powerpc/platforms/85xx/Makefile | 1 +
+ arch/powerpc/boot/Makefile | 3 ++-
+ arch/powerpc/boot/wrapper | 5 +++++
+ arch/powerpc/platforms/85xx/Kconfig | 11 +++++++++++
+ arch/powerpc/platforms/85xx/Makefile | 1 +
+ 4 files changed, 19 insertions(+), 1 deletion(-)
+diff --git a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
+index e2a5a932c24a..925140f8350b 100644
--- a/arch/powerpc/boot/Makefile
+++ b/arch/powerpc/boot/Makefile
-@@ -156,6 +156,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
+@@ -156,6 +156,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pseries-head.S
src-plat-$(CONFIG_PPC_POWERNV) += pseries-head.S
src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
-+src-plat-$(CONFIG_TL_WDR4900_V1) += cuboot-tl-wdr4900-v1.c
++src-plat-$(CONFIG_TL_WDR4900_V1) += simpleboot.c fixed-head.S
src-wlib := $(sort $(src-wlib-y))
src-plat := $(sort $(src-plat-y))
-@@ -335,7 +336,7 @@ image-$(CONFIG_TQM8555) += cuImage.tqm
+@@ -335,7 +336,7 @@ image-$(CONFIG_TQM8555) += cuImage.tqm8555
image-$(CONFIG_TQM8560) += cuImage.tqm8560
image-$(CONFIG_SBC8548) += cuImage.sbc8548
image-$(CONFIG_KSI8560) += cuImage.ksi8560
-
-+image-$(CONFIG_TL_WDR4900_V1) += cuImage.tl-wdr4900-v1
++image-$(CONFIG_TL_WDR4900_V1) += simpleImage.tl-wdr4900-v1
# Board ports in arch/powerpc/platform/86xx/Kconfig
image-$(CONFIG_MVME7100) += dtbImage.mvme7100
+diff --git a/arch/powerpc/boot/wrapper b/arch/powerpc/boot/wrapper
+index 76fe3ccfd381..96fd853a1ed0 100755
--- a/arch/powerpc/boot/wrapper
+++ b/arch/powerpc/boot/wrapper
-@@ -277,6 +277,10 @@ cuboot*)
- *-mpc85*|*-tqm85*|*-sbc85*)
- platformo=$object/cuboot-85xx.o
- ;;
-+ *-tl-wdr4900-v1)
-+ platformo=$object/cuboot-tl-wdr4900-v1.o
+@@ -302,6 +302,11 @@ adder875-redboot)
+ platformo="$object/fixed-head.o $object/redboot-8xx.o"
+ binary=y
+ ;;
++simpleboot-tl-wdr4900-v1)
++ platformo="$object/fixed-head.o $object/simpleboot.o"
+ link_address='0x1000000'
-+ ;;
- *-amigaone)
- link_address='0x800000'
- ;;
++ binary=y
++ ;;
+ simpleboot-virtex405-*)
+ platformo="$object/virtex405-head.o $object/simpleboot.o $object/virtex.o"
+ binary=y
+diff --git a/arch/powerpc/platforms/85xx/Kconfig b/arch/powerpc/platforms/85xx/Kconfig
+index 68920d42b4bc..477782740f0e 100644
--- a/arch/powerpc/platforms/85xx/Kconfig
+++ b/arch/powerpc/platforms/85xx/Kconfig
@@ -170,6 +170,17 @@ config STX_GP3
@@ -67,9 +76,11 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
config TQM8540
bool "TQ Components TQM8540"
help
+diff --git a/arch/powerpc/platforms/85xx/Makefile b/arch/powerpc/platforms/85xx/Makefile
+index d1dd0dca5ebf..d0dab29a33eb 100644
--- a/arch/powerpc/platforms/85xx/Makefile
+++ b/arch/powerpc/platforms/85xx/Makefile
-@@ -26,6 +26,7 @@ obj-$(CONFIG_CORENET_GENERIC) += coren
+@@ -26,6 +26,7 @@ obj-$(CONFIG_CORENET_GENERIC) += corenet_generic.o
obj-$(CONFIG_FB_FSL_DIU) += t1042rdb_diu.o
obj-$(CONFIG_STX_GP3) += stx_gp3.o
obj-$(CONFIG_TQM85xx) += tqm85xx.o
@@ -77,3 +88,6 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
obj-$(CONFIG_SBC8548) += sbc8548.o
obj-$(CONFIG_PPA8548) += ppa8548.o
obj-$(CONFIG_SOCRATES) += socrates.o socrates_fpga_pic.o
+--
+2.20.1
+