aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/patches-4.14
diff options
context:
space:
mode:
authorRyan Mounce <ryan@mounce.com.au>2018-10-12 18:16:28 +1030
committerHauke Mehrtens <hauke@hauke-m.de>2018-10-20 16:24:29 +0200
commit4d2613b01ac6d34c2de550472ad9167e28ebd11e (patch)
tree73270600a89874eeb362da2ab7000b44f59d5db7 /target/linux/mpc85xx/patches-4.14
parent5f2cb6d7dc9de24bec7b1139f8d785f0e7588eed (diff)
downloadupstream-4d2613b01ac6d34c2de550472ad9167e28ebd11e.tar.gz
upstream-4d2613b01ac6d34c2de550472ad9167e28ebd11e.tar.bz2
upstream-4d2613b01ac6d34c2de550472ad9167e28ebd11e.zip
mpc85xx: workaround 4.14 cross compile issue
Regression introduced with 4.10 by 43c9127d94d62a232ed33ed2eab8a08657ce5472 Build will fail if system 'ar' does not support deterministic builds. e.g. macOS with Xcode toolchain Appears to be fixed upstream in 4.18 by af3901cbbd3de182aafb8ee553c825c0074df6a2 Signed-off-by: Ryan Mounce <ryan@mounce.com.au>
Diffstat (limited to 'target/linux/mpc85xx/patches-4.14')
-rw-r--r--target/linux/mpc85xx/patches-4.14/103-powerpc-fix-build-cross32ar.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/patches-4.14/103-powerpc-fix-build-cross32ar.patch b/target/linux/mpc85xx/patches-4.14/103-powerpc-fix-build-cross32ar.patch
new file mode 100644
index 0000000000..7ed52f649c
--- /dev/null
+++ b/target/linux/mpc85xx/patches-4.14/103-powerpc-fix-build-cross32ar.patch
@@ -0,0 +1,10 @@
+--- a/arch/powerpc/Makefile
++++ b/arch/powerpc/Makefile
+@@ -23,6 +23,7 @@ CROSS32AR := $(CROSS32_COMPILE)ar
+ ifeq ($(HAS_BIARCH),y)
+ ifeq ($(CROSS32_COMPILE),)
+ CROSS32CC := $(CC) -m32
++CROSS32AR := $(AR)
+ KBUILD_ARFLAGS += --target=elf32-powerpc
+ endif
+ endif