aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/patches-4.14/101-powerpc-85xx-hiveap-330-support.patch
diff options
context:
space:
mode:
authorMagnus Kroken <mkroken@gmail.com>2018-10-06 01:46:22 +0200
committerJohn Crispin <john@phrozen.org>2018-10-11 08:03:56 +0200
commitc83c1804891ac706f2e82f9d6c0aaf6ba290348a (patch)
tree3204894923b23007ea2b2bce988bb8c17cb2a482 /target/linux/mpc85xx/patches-4.14/101-powerpc-85xx-hiveap-330-support.patch
parentf4b7dfcc4beede9acd8f503b121aed158e38a11d (diff)
downloadupstream-c83c1804891ac706f2e82f9d6c0aaf6ba290348a.tar.gz
upstream-c83c1804891ac706f2e82f9d6c0aaf6ba290348a.tar.bz2
upstream-c83c1804891ac706f2e82f9d6c0aaf6ba290348a.zip
mpc85xx: add kernel 4.14 support
Based on patches previously submitted by Achim Gottinger: http://lists.infradead.org/pipermail/openwrt-devel/2018-June/012719.html Tested on TP-Link TL-WDR4900 v1. Signed-off-by: Magnus Kroken <mkroken@gmail.com>
Diffstat (limited to 'target/linux/mpc85xx/patches-4.14/101-powerpc-85xx-hiveap-330-support.patch')
-rw-r--r--target/linux/mpc85xx/patches-4.14/101-powerpc-85xx-hiveap-330-support.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/patches-4.14/101-powerpc-85xx-hiveap-330-support.patch b/target/linux/mpc85xx/patches-4.14/101-powerpc-85xx-hiveap-330-support.patch
new file mode 100644
index 0000000000..519566bc15
--- /dev/null
+++ b/target/linux/mpc85xx/patches-4.14/101-powerpc-85xx-hiveap-330-support.patch
@@ -0,0 +1,30 @@
+--- a/arch/powerpc/platforms/85xx/Kconfig
++++ b/arch/powerpc/platforms/85xx/Kconfig
+@@ -49,6 +49,17 @@ config BSC9132_QDS
+ and dual StarCore SC3850 DSP cores.
+ Manufacturer : Freescale Semiconductor, Inc
+
++config HIVEAP_330
++ bool "Aerohive HiveAP-330"
++ select DEFAULT_UIMAGE
++ select ARCH_REQUIRE_GPIOLIB
++ select GPIO_MPC8XXX
++ help
++ This option enables support for the Aerohive HiveAP-330 board.
++
++ This board is a Concurrent Dual-Band wireless access point with a
++ Freescale P1020 SoC.
++
+ config MPC8540_ADS
+ bool "Freescale MPC8540 ADS"
+ select DEFAULT_UIMAGE
+--- a/arch/powerpc/platforms/85xx/Makefile
++++ b/arch/powerpc/platforms/85xx/Makefile
+@@ -10,6 +10,7 @@ obj-y += common.o
+ obj-$(CONFIG_BSC9131_RDB) += bsc913x_rdb.o
+ obj-$(CONFIG_BSC9132_QDS) += bsc913x_qds.o
+ obj-$(CONFIG_C293_PCIE) += c293pcie.o
++obj-$(CONFIG_HIVEAP_330) += hiveap-330.o
+ obj-$(CONFIG_MPC8540_ADS) += mpc85xx_ads.o
+ obj-$(CONFIG_MPC8560_ADS) += mpc85xx_ads.o
+ obj-$(CONFIG_MPC85xx_CDS) += mpc85xx_cds.o