aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/p1020
diff options
context:
space:
mode:
authorChris Blake <chrisrblake93@gmail.com>2017-10-20 12:36:25 -0500
committerMathias Kresin <dev@kresin.me>2017-10-25 09:21:54 +0200
commitec269290db46d491ae61adb64b19b3f171b8e2a3 (patch)
tree91602b2a24759dd57794878f1afb0f7769dbda92 /target/linux/mpc85xx/p1020
parentdcf62cb24efb2fd69eca921085c3f4306e76e8a2 (diff)
downloadupstream-ec269290db46d491ae61adb64b19b3f171b8e2a3.tar.gz
upstream-ec269290db46d491ae61adb64b19b3f171b8e2a3.tar.bz2
upstream-ec269290db46d491ae61adb64b19b3f171b8e2a3.zip
mpc85xx: use new build code style
The following moves the mpc85xx target (generic & P1020) to the new build code style. Compile & Flash tested on an Aerohive HiveAP-330. Signed-off-by: Chris Blake <chrisrblake93@gmail.com> Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/mpc85xx/p1020')
-rw-r--r--target/linux/mpc85xx/p1020/profiles/00-default.mk15
-rw-r--r--target/linux/mpc85xx/p1020/profiles/aerohive.mk16
2 files changed, 15 insertions, 16 deletions
diff --git a/target/linux/mpc85xx/p1020/profiles/00-default.mk b/target/linux/mpc85xx/p1020/profiles/00-default.mk
new file mode 100644
index 0000000000..67d43020a2
--- /dev/null
+++ b/target/linux/mpc85xx/p1020/profiles/00-default.mk
@@ -0,0 +1,15 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PRIORITY:=1
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most P1020 boards.
+endef
+
+$(eval $(call Profile,Default))
diff --git a/target/linux/mpc85xx/p1020/profiles/aerohive.mk b/target/linux/mpc85xx/p1020/profiles/aerohive.mk
deleted file mode 100644
index 0f5ace6c39..0000000000
--- a/target/linux/mpc85xx/p1020/profiles/aerohive.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2017 Chris Blake <chrisrblake93@gmail.com>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/hiveap-330
- NAME:=Aerohive HiveAP-330
- PACKAGES:=kmod-usb-storage kmod-ath9k wpad-mini kmod-tpm-i2c-atmel
-endef
-
-define Profile/hiveap-330/Description
- Package set optimized for the Aerohive HiveAP-330.
-endef
-$(eval $(call Profile,hiveap-330))