aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/p1020/profiles
diff options
context:
space:
mode:
authorChris Blake <chrisrblake93@gmail.com>2017-09-30 11:14:58 -0500
committerHauke Mehrtens <hauke@hauke-m.de>2017-10-14 01:23:47 +0200
commitf2b7d9dc1ca3d33f14961cf2885639f4f9e8965e (patch)
tree10f2ed5de3ed465cd70c1e02fc23d1fefe92e2a6 /target/linux/mpc85xx/p1020/profiles
parent8cd6686ef81effb3c30f0508368db3d0600f289d (diff)
downloadupstream-f2b7d9dc1ca3d33f14961cf2885639f4f9e8965e.tar.gz
upstream-f2b7d9dc1ca3d33f14961cf2885639f4f9e8965e.tar.bz2
upstream-f2b7d9dc1ca3d33f14961cf2885639f4f9e8965e.zip
mpc85xx: Add Aerohive HiveAP-330 Access Point
The following adds the Aerohive HiveAP-330 Access Point to LEDE under the mpc85xx/p1020 subtarget. Hardware: - SoC: Freescale P1020NSE2DFB - NAND: Intel JS28F512M29EWH 64MB - Memory: 2x ProMOS V59C1G01168QBJ3 128MB (Total of 256MB) - 2.4GHz WiFi: Atheros AR9390-AL1A - 5.0GHz WiFi: Atheros AR9390-AL1A - Eth1: Atheros AR8035-A PoE - Eth2: Atheros AR8035-A - TPM: Atmel AT97SC3204 - LED Driver: TI LP5521 Flashing: 1. Hook into UART (9600 baud) and enter U-Boot. You may need to enter a password of administrator or AhNf?d@ta06 if prompted. 2. Once in U-Boot, tftp boot the initramfs image: dhcp; tftpboot 0x1000000 192.168.1.101:lede- mpc85xx-p1020-hiveap-330-initramfs.zImage; tftpboot 0x6000000 192.168.1.101:lede-mpc85xx-p1020-hiveap-330.fdt; bootm 0x1000000 - 0x6000000; 3. Once booted, scp over the sysupgrade file and sysupgrade the device to flash LEDE to the NAND. sysupgrade /tmp/lede-mpc85xx-p1020-hiveap-330-sysupgrade.img Signed-off-by: Chris Blake <chrisrblake93@gmail.com>
Diffstat (limited to 'target/linux/mpc85xx/p1020/profiles')
-rw-r--r--target/linux/mpc85xx/p1020/profiles/aerohive.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/p1020/profiles/aerohive.mk b/target/linux/mpc85xx/p1020/profiles/aerohive.mk
new file mode 100644
index 0000000000..0f5ace6c39
--- /dev/null
+++ b/target/linux/mpc85xx/p1020/profiles/aerohive.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2017 Chris Blake <chrisrblake93@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/hiveap-330
+ NAME:=Aerohive HiveAP-330
+ PACKAGES:=kmod-usb-storage kmod-ath9k wpad-mini kmod-tpm-i2c-atmel
+endef
+
+define Profile/hiveap-330/Description
+ Package set optimized for the Aerohive HiveAP-330.
+endef
+$(eval $(call Profile,hiveap-330))