aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/image
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2023-03-20 04:50:14 +0100
committerDavid Bauer <mail@david-bauer.net>2023-03-20 22:21:22 +0100
commited82189339b8bcecfe709f1ce8f3500fb4aedab1 (patch)
tree5095748ed807b48b447196d46746d885e22eceeb /target/linux/mpc85xx/image
parente314f7be7e9e878d2f6470c9d9e0030cd4f1f700 (diff)
downloadupstream-ed82189339b8bcecfe709f1ce8f3500fb4aedab1.tar.gz
upstream-ed82189339b8bcecfe709f1ce8f3500fb4aedab1.tar.bz2
upstream-ed82189339b8bcecfe709f1ce8f3500fb4aedab1.zip
mpc85xx: use bootwrapper for ws-ap3825i
The boot-procedure for the Extreme WS-AP3825I is vfragile to put it mildly. It does not relocate the FDT properly. It currently exercises every step manually as well as coming with a pre-padded dtb. Use the PowerPC bootwrapper code for legacy platforms with a pre-filles DTS instead. We still need to ship a fit image to not break the fdt resize / relocate instructions on existing boards. This does not require adapting the U-Boot bootcommand. Ref: https://github.com/openwrt/openwrt/issues/12223 Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/mpc85xx/image')
-rw-r--r--target/linux/mpc85xx/image/p1020.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/mpc85xx/image/p1020.mk b/target/linux/mpc85xx/image/p1020.mk
index 6fdbfd664a..1f17de3f55 100644
--- a/target/linux/mpc85xx/image/p1020.mk
+++ b/target/linux/mpc85xx/image/p1020.mk
@@ -73,8 +73,10 @@ define Device/extreme-networks_ws-ap3825i
DEVICE_MODEL := WS-AP3825i
DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
BLOCKSIZE := 128k
- DTB_SIZE := 20480
- KERNEL = kernel-bin | lzma | pad-dtb | fit lzma $(KDIR)/image-$$(DEVICE_DTS).dtb
+ KERNEL_NAME := simpleImage.ws-ap3825i
+ KERNEL_ENTRY := 0x1000000
+ KERNEL_LOADADDR := 0x1000000
+ KERNEL = kernel-bin | lzma | fit lzma $(KDIR)/image-$$(DEVICE_DTS).dtb
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
endef