aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/image
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2023-02-18 02:06:54 +0100
committerDavid Bauer <mail@david-bauer.net>2023-03-07 14:05:02 +0100
commit35f6d795134e9b089c4e763a7f58cba7d4e15e42 (patch)
treec83defadb19a22b45ec465288484187a050ce823 /target/linux/mpc85xx/image
parent635d177ac95e0ba21fc0b4f26dcc9c7bcd516cca (diff)
downloadupstream-35f6d795134e9b089c4e763a7f58cba7d4e15e42.tar.gz
upstream-35f6d795134e9b089c4e763a7f58cba7d4e15e42.tar.bz2
upstream-35f6d795134e9b089c4e763a7f58cba7d4e15e42.zip
mpc85xx: add support for Watchguard Firebox T10
Hardware -------- SoC: Freescale P1010 RAM: 512MB FLASH: 1 MB SPI-NOR 512 MB NAND ETH: 3x Gigabite Ethernet (Atheros AR8033) SERIAL: Cisco RJ-45 (115200 8N1) RTC: Battery-Backed RTC (I2C) Installation ------------ 1. Patch U-Boot by dumping the content of the SPI-Flash using a SPI programmer. The SHA1 hash for the U-Boot password is currently unknown. A tool for patching U-Boot is available at https://github.com/blocktrron/t10-uboot-patcher/ You can also patch the unknown password yourself. The SHA1 hash is E597301A1D89FF3F6D318DBF4DBA0A5ABC5ECBEA 2. Interrupt the bootmenu by pressing CTRL+C. A password prompt appears. The patched password is '1234' (without quotation marks) 3. Download the OpenWrt initramfs image. Copy it to a TFTP server reachable at 10.0.1.13/24 and rename it to uImage. 4. Connect the TFTP server to ethernet port 0 of the Watchguard T10. 5. Download and boot the initramfs image by entering "tftpboot; bootm;" in U-Boot. 6. After OpenWrt booted, create a UBI volume on the old data partition. The "ubi" mtd partition should be mtd7, check this using $ cat /proc/mtd Create a UBI partition by executing $ ubiformat /dev/mtd7 -y 7. Increase the loadable kernel-size of U-Boot by executing $ fw_setenv SysAKernSize 800000 8. Transfer the OpenWrt sysupgrade image to the Watchguard T10 using scp. Install the image by using sysupgrade: $ sysupgrade -n <path-to-sysupgrade> Note: The LAN ports of the T10 are 1 & 2 while 0 is WAN. You might have to change the ethernet-port. 9. OpenWrt should now boot from the internal NAND. Enjoy. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/mpc85xx/image')
-rw-r--r--target/linux/mpc85xx/image/p1010.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/image/p1010.mk b/target/linux/mpc85xx/image/p1010.mk
index 92cad3d035..90ef46d709 100644
--- a/target/linux/mpc85xx/image/p1010.mk
+++ b/target/linux/mpc85xx/image/p1010.mk
@@ -40,6 +40,16 @@ define Device/tplink_tl-wdr4900-v1
endef
TARGET_DEVICES += tplink_tl-wdr4900-v1
+define Device/watchguard_firebox-t10
+ DEVICE_VENDOR := Watchguard
+ DEVICE_MODEL := Firebox T10
+ DEVICE_PACKAGES := kmod-rtc-s35390a kmod-eeprom-at24
+ KERNEL = kernel-bin | gzip | fit gzip $(KDIR)/image-$$(DEVICE_DTS).dtb
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+endef
+TARGET_DEVICES += watchguard_firebox-t10
+
define Device/sophos_red-15w-rev1
DEVICE_VENDOR := Sophos
DEVICE_MODEL := RED 15w