aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/image
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-10-24 06:57:29 +0200
committerMathias Kresin <dev@kresin.me>2017-10-25 09:22:13 +0200
commit605ce5f6cd8098f3813b44a64f8f1ac61cc92470 (patch)
tree32ec11ad7fcc9e02d2279a4d62c02038c9995bf6 /target/linux/mpc85xx/image
parentdcbbac55edbcc97e1ba320149eba886d3ab901b0 (diff)
downloadupstream-605ce5f6cd8098f3813b44a64f8f1ac61cc92470.tar.gz
upstream-605ce5f6cd8098f3813b44a64f8f1ac61cc92470.tar.bz2
upstream-605ce5f6cd8098f3813b44a64f8f1ac61cc92470.zip
mpc85xx: use image metadata
Append and enforce image metadata. Remove the device specific image checks, they are replaced by image metadata. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/mpc85xx/image')
-rw-r--r--target/linux/mpc85xx/image/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index f7de3bc5ce..7ae6e27b35 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -46,10 +46,11 @@ define Device/tl-wdr4900-v1
TPLINK_HWREV := 1
TPLINK_FLASHLAYOUT := 16Mppc
KERNEL_NAME := cuImage.tl-wdr4900-v1
+ SUPPORTED_DEVICES:=tl-wdr4900-v1 tplink,tl-wdr4900-v1
IMAGES := fdt.bin factory.bin sysupgrade.bin
IMAGE/fdt.bin := append-dtb
IMAGE/factory.bin := tplink-v1-image
- IMAGE/sysupgrade.bin := tplink-v1-image -s
+ IMAGE/sysupgrade.bin := tplink-v1-image -s | append-metadata
endef
TARGET_DEVICES += tl-wdr4900-v1
@@ -63,12 +64,13 @@ define Device/hiveap-330
BLOCKSIZE := 128k
KERNEL_NAME := zImage
KERNEL_SIZE := 8m
+ SUPPORTED_DEVICES := aerohive,hiveap-330
IMAGES := fdt.bin sysupgrade.bin
IMAGE/fdt.bin := append-dtb
IMAGE/sysupgrade.bin := append-dtb | pad-to 256k | check-size 256k | \
append-uImage-fakeramdisk-hdr | pad-to 256k | check-size 512k | \
append-rootfs | pad-rootfs $$(BLOCKSIZE) | pad-to 41216k | check-size 41216k | \
- append-kernel
+ append-kernel | append-metadata
endef
TARGET_DEVICES += hiveap-330