aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/image/p2020.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-05-18 21:10:45 +0200
committerDavid Bauer <mail@david-bauer.net>2020-05-18 21:11:39 +0200
commit4133304413b81ce39ec88d6e483e46a95e2fbe2f (patch)
tree109264716375338c39c8b9041cf6911a7385e976 /target/linux/mpc85xx/image/p2020.mk
parent564f87ef5bea16d5d1d8a9a80e8de77429159f26 (diff)
downloadupstream-4133304413b81ce39ec88d6e483e46a95e2fbe2f.tar.gz
upstream-4133304413b81ce39ec88d6e483e46a95e2fbe2f.tar.bz2
upstream-4133304413b81ce39ec88d6e483e46a95e2fbe2f.zip
mpc85xx: restructure image receipts
Move the image receipts into separate per-subtarget files like it is done on most other targets. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/mpc85xx/image/p2020.mk')
-rw-r--r--target/linux/mpc85xx/image/p2020.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/image/p2020.mk b/target/linux/mpc85xx/image/p2020.mk
new file mode 100644
index 0000000000..79b5fa660c
--- /dev/null
+++ b/target/linux/mpc85xx/image/p2020.mk
@@ -0,0 +1,15 @@
+define Device/freescale_p2020rdb
+ DEVICE_VENDOR := Freescale
+ DEVICE_MODEL := P2020RDB
+ DEVICE_DTS_DIR := $(DTS_DIR)/fsl
+ DEVICE_PACKAGES := kmod-hwmon-lm90 kmod-rtc-ds1307 \
+ kmod-gpio-pca953x kmod-eeprom-at24
+ BLOCKSIZE := 128k
+ KERNEL := kernel-bin | gzip | \
+ fit gzip $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+ SUPPORTED_DEVICES := fsl,P2020RDB
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
+ pad-rootfs $$(BLOCKSIZE) | append-metadata
+endef
+TARGET_DEVICES += freescale_p2020rdb