aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/image/Makefile
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2019-12-13 21:31:50 +0100
committerDavid Bauer <mail@david-bauer.net>2019-12-14 17:34:57 +0100
commit795df809176aa6f19ff6994c3ae1d9bfb309639c (patch)
tree6cf604c158de691c060705d8bd0d2e41744711d5 /target/linux/mpc85xx/image/Makefile
parent3959f11005965eb536396a8c258f0ab944eb598d (diff)
downloadupstream-795df809176aa6f19ff6994c3ae1d9bfb309639c.tar.gz
upstream-795df809176aa6f19ff6994c3ae1d9bfb309639c.tar.bz2
upstream-795df809176aa6f19ff6994c3ae1d9bfb309639c.zip
mpc85xx: add support for Enterasys WS-AP3710i
Hardware -------- SoC: NXP P1020 (2x e500 @ 800MHz) RAM: 256M DDR3 (Micron) FLASH: 32M NOR (Spansion S29GL128S) BTN: 1x Reset WiFi: 1x Atheros AR9590 2.4 bgn 3x3 2x Atheros AR9590 5.0 an 3x3 ETH: 1x Gigabit Ethernet (Atheros AR8033) LED: System (green/red) - Radio{0,1} (green) LAN (connected to PHY) - GE blue - FE green Serial is a Cisco-compatible RJ45 next to the ethernet port. 115200-N-8 are the settings for OS and U-Boot. Installation ------------ 1. Grab the OpenWrt initramfs, rename it to 01C8A8C0.img. Place it in the root directory of a TFTP server and serve it at 192.168.200.200/24. 2. Connect to the serial port and boot the AP. Stop autoboot in U-Boot by pressing Enter when prompted. Credentials are identical to the one in the APs interface. By default it is admin / new2day. 3. Set the bootcmd so the AP can boot OpenWrt by executing $ setenv boot_openwrt "setenv bootargs; cp.b 0xee000000 0x1000000 0x1000000; bootm 0x1000000" $ setenv bootcmd "run boot_openwrt" $ saveenv If you plan on going back to the vendor firmware - the bootcmd for it is stored in the boot_flash variable. 4. Load the initramfs image to RAM and boot by executing $ tftpboot 0x1000000 192.168.200.200:01C8A8C0.img; bootm 5. Make a backup of the "firmware" partition if you ever wish to go back to the vendor firmware. 6. Upload the OpenWrt sysupgrade image via SCP to the devices /tmp folder. 7. Flash OpenWrt using sysupgrade. $ sysupgrade -n /tmp/openwrt-sysupgrade.bin Signed-off-by: David Bauer <mail@david-bauer.net> (cherry picked from commit 16b01fb1b9c99513c318109bef96a1a3545c57a0)
Diffstat (limited to 'target/linux/mpc85xx/image/Makefile')
-rw-r--r--target/linux/mpc85xx/image/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index c2ddcb32c5..c0e3112741 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -98,6 +98,16 @@ define Device/hiveap-330
endef
TARGET_DEVICES += hiveap-330
+define Device/ws-ap3710i
+ DEVICE_TITLE := Enterasys WS-AP3710i
+ BLOCKSIZE := 128k
+ KERNEL = kernel-bin | lzma | fit lzma $(KDIR)/image-$$(DEVICE_DTS).dtb
+ SUPPORTED_DEVICES := enterasys,ws-ap3710i
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+endef
+TARGET_DEVICES += ws-ap3710i
+
define Device/panda
DEVICE_TITLE := OCEDO Panda
DEVICE_PACKAGES := kmod-rtc-ds1307 uboot-envtools