aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-09-04 13:34:18 +0200
committerFelix Fietkau <nbd@nbd.name>2016-09-04 13:35:11 +0200
commitaa53f78038d541052de8764323f6f26578327606 (patch)
tree6b727dbb60f75aee3db17e8e84777c143cba22d2 /target/linux/mpc85xx/Makefile
parenta810e7789ab52b65dca7c3dc74e0b96f44679950 (diff)
downloadupstream-aa53f78038d541052de8764323f6f26578327606.tar.gz
upstream-aa53f78038d541052de8764323f6f26578327606.tar.bz2
upstream-aa53f78038d541052de8764323f6f26578327606.zip
build: fix subtarget descriptions
Move Target/Description above the target.mk include Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/mpc85xx/Makefile')
-rw-r--r--target/linux/mpc85xx/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
index efd48d7d41..7f986452c5 100644
--- a/target/linux/mpc85xx/Makefile
+++ b/target/linux/mpc85xx/Makefile
@@ -16,6 +16,10 @@ SUBTARGETS=generic p1020
KERNEL_PATCHVER:=4.4
+define Target/Description
+ Build images for the Freescale MPC85xx based boards.
+endef
+
include $(INCLUDE_DIR)/target.mk
KERNEL_IMAGES := zImage
@@ -27,8 +31,4 @@ DEFAULT_PACKAGES += \
kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
kmod-leds-gpio swconfig kmod-ath9k wpad-mini
-define Target/Description
- Build images for the Freescale MPC85xx based boards.
-endef
-
$(eval $(call BuildTarget))
d='n207' href='#n207'>207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275
/*
    ChibiOS/RT - Copyright (C) 2006-2007 Giovanni Di Sirio.

    This file is part of ChibiOS/RT.

    ChibiOS/RT is free software; you can redistribute it and/or modify
    it under the terms of the GNU General Public License as published by
    the Free Software Foundation; either version 3 of the License, or
    (at your option) any later version.

    ChibiOS/RT is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
    GNU General Public License for more details.

    You should have received a copy of the GNU General Public License
    along with this program.  If not, see <http://www.gnu.org/licenses/>.
*/

#include <stdio.h>
#include <string.h>

#include "ch.h"
#include "hal.h"
#include "test.h"
#include "evtimer.h"
#include "buzzer.h"

#include "ff.h"

/**
 * @brief FS object.
 */
FATFS MMC_FS;

/**
 * MMC driver instance.
 */
MMCDriver MMCD1;

/* FS mounted and ready.*/
static bool_t fs_ready = FALSE;

/* Maximum speed SPI configuration (18MHz, CPHA=0, CPOL=0).*/
static SPIConfig hs_spicfg = {
  IOPORT1,
  PA_SSEL1,
  CR0_DSS8BIT | CR0_FRFSPI | CR0_CLOCKRATE(0),