aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2010-12-05 11:38:59 +0000
committerImre Kaloz <kaloz@openwrt.org>2010-12-05 11:38:59 +0000
commit0ebaa8e8018686fb86c591754384c4ec6ed9c4e2 (patch)
tree9eb814753f6d25186970d24b912df98928da89d6 /target/linux/mpc85xx/Makefile
parentbceed84c5efcae1c29e5622de9a26b47838f7b89 (diff)
downloadupstream-0ebaa8e8018686fb86c591754384c4ec6ed9c4e2.tar.gz
upstream-0ebaa8e8018686fb86c591754384c4ec6ed9c4e2.tar.bz2
upstream-0ebaa8e8018686fb86c591754384c4ec6ed9c4e2.zip
[target/mpc85xx]: preliminary support for Freescale MPC85xx based boards
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24259 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mpc85xx/Makefile')
-rw-r--r--target/linux/mpc85xx/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
new file mode 100644
index 0000000000..96e7763129
--- /dev/null
+++ b/target/linux/mpc85xx/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=powerpc
+BOARD:=mpc85xx
+BOARDNAME:=Freescale MPC85xx
+CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=8540
+FEATURES:=fpu ramdisk broken
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+
+LINUX_VERSION:=2.6.36.1
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build images for the Freescale MPC85xx based boards.
+endef
+
+$(eval $(call BuildTarget))