aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc83xx
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
commit6a4f2922f6303a006d66b4bbb79541823b1c12b4 (patch)
treed3d9644c2a4a2e9b758bab9b84973e078143ed2c /target/linux/mpc83xx
parenteab95ea46736f8359c5a19a612f0e39160cab80c (diff)
downloadupstream-6a4f2922f6303a006d66b4bbb79541823b1c12b4.tar.gz
upstream-6a4f2922f6303a006d66b4bbb79541823b1c12b4.tar.bz2
upstream-6a4f2922f6303a006d66b4bbb79541823b1c12b4.zip
targets: prepare for supporting normal and initramfs images
In order to support both normal images and initramfs, ensure that each target sets KERNELNAME properly so that the generic kernel building code can copy the corresponding files over $(KDIR) with the appropriate extension. Update the various paths to the kernel and wrapper images from $(LINUX_DIR)/arch/$(ARCH)/boot/$(foo) to $(KDIR)/$(foo). Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 37049
Diffstat (limited to 'target/linux/mpc83xx')
-rw-r--r--target/linux/mpc83xx/Makefile2
-rw-r--r--target/linux/mpc83xx/image/Makefile2
2 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/mpc83xx/Makefile b/target/linux/mpc83xx/Makefile
index bc52368f06..2a721dace0 100644
--- a/target/linux/mpc83xx/Makefile
+++ b/target/linux/mpc83xx/Makefile
@@ -23,4 +23,6 @@ define Target/Description
Build firmware images for Freescale MPC83xx based boards (eg. RouterBoard 600).
endef
+KERNELNAME:="uImage"
+
$(eval $(call BuildTarget))
diff --git a/target/linux/mpc83xx/image/Makefile b/target/linux/mpc83xx/image/Makefile
index aabfbad4d1..c7458f1c24 100644
--- a/target/linux/mpc83xx/image/Makefile
+++ b/target/linux/mpc83xx/image/Makefile
@@ -15,7 +15,7 @@ endef
define Image/BuildKernel
cp $(LINUX_DIR)/arch/powerpc/boot/dtbImage.rb600.elf $(BIN_DIR)/openwrt-$(BOARD)-rb600.elf
cp $(LINUX_DIR)/arch/powerpc/boot/dtbImage.rb333.elf $(BIN_DIR)/openwrt-$(BOARD)-rb333.elf
- cp $(LINUX_DIR)/arch/powerpc/boot/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
endef
define Image/Build