aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc83xx/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-07-29 10:25:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-07-29 10:25:40 +0000
commit155510ec8e938f5bea4a35a5e11d93b81ed6bd20 (patch)
treed74d016bc5e75029d5fd0aa187c01177408993d5 /target/linux/mpc83xx/image/Makefile
parenta40fb63ca6c4dbe2868f2e11d1d9985f31de131c (diff)
downloadupstream-155510ec8e938f5bea4a35a5e11d93b81ed6bd20.tar.gz
upstream-155510ec8e938f5bea4a35a5e11d93b81ed6bd20.tar.bz2
upstream-155510ec8e938f5bea4a35a5e11d93b81ed6bd20.zip
BB: remove some targets that are broken or have the wrong kernel version
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@41876 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mpc83xx/image/Makefile')
-rw-r--r--target/linux/mpc83xx/image/Makefile33
1 files changed, 0 insertions, 33 deletions
diff --git a/target/linux/mpc83xx/image/Makefile b/target/linux/mpc83xx/image/Makefile
deleted file mode 100644
index 8770390b2d..0000000000
--- a/target/linux/mpc83xx/image/Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
-#
-# Copyright (C) 2009-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
-
-
-define Image/Prepare
- $(LINUX_DIR)/scripts/dtc/dtc -O dtb -R 4 -S 0x20000 $(DTS_DIR)/mpc8377_wlan.dts > $(BIN_DIR)/openwrt-mpc83xx-mpc8377_wlan.dtb
-endef
-
-define Image/BuildKernel
- cp $(LINUX_DIR)/arch/powerpc/boot/dtbImage.rb600.elf $(BIN_DIR)/openwrt-$(BOARD)-rb600.elf
- cp $(LINUX_DIR)/arch/powerpc/boot/dtbImage.rb333.elf $(BIN_DIR)/openwrt-$(BOARD)-rb333.elf
- cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
-endef
-
-define Image/Build
- $(call Image/Build/$(1),$(1))
-endef
-
-define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
- ( \
- dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=3072k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
- ) > $(BIN_DIR)/$(IMG_PREFIX)-mpc8377_wlan-$(1).img
-endef
-
-$(eval $(call BuildImage))