aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc52xx/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-07-28 15:51:32 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-07-28 15:51:32 +0000
commita63f8633f06f5f785391c006fad57333a2cebc46 (patch)
tree22943e07bc8bd2c0955d051844ba9e8297e02c5e /target/linux/mpc52xx/Makefile
parent57eaa31a128a601148d87a884ccdb5c06f371be0 (diff)
downloadupstream-a63f8633f06f5f785391c006fad57333a2cebc46.tar.gz
upstream-a63f8633f06f5f785391c006fad57333a2cebc46.tar.bz2
upstream-a63f8633f06f5f785391c006fad57333a2cebc46.zip
add new target for Freescale MPC52xx based boards
SVN-Revision: 17037
Diffstat (limited to 'target/linux/mpc52xx/Makefile')
-rw-r--r--target/linux/mpc52xx/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/mpc52xx/Makefile b/target/linux/mpc52xx/Makefile
new file mode 100644
index 0000000000..f36c8836bb
--- /dev/null
+++ b/target/linux/mpc52xx/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=powerpc
+BOARD:=mpc52xx
+BOARDNAME:=Freescale MPC52xx
+FEATURES:=tgz ext2
+
+LINUX_VERSION:=2.6.30.3
+LINUX_KARCH:=powerpc
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build images for the Freescale MPC52xx based boards.
+endef
+
+$(eval $(call BuildTarget))