aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek
diff options
context:
space:
mode:
authorWenli Looi <wlooi@ucalgary.ca>2023-03-30 22:27:11 +0000
committerDaniel Golle <daniel@makrotopia.org>2023-07-13 12:05:28 +0100
commit977ee439d7068e405361322013e9a2114bfefcda (patch)
tree45f519f8cc792cbf56981131f70b46da4335bf8c /target/linux/mediatek
parentb7fac1bf8c6f975607427734f85318c69aacaeb6 (diff)
downloadupstream-977ee439d7068e405361322013e9a2114bfefcda.tar.gz
upstream-977ee439d7068e405361322013e9a2114bfefcda.tar.bz2
upstream-977ee439d7068e405361322013e9a2114bfefcda.zip
image: add additional fields to Netgear encrypted image
These fields are used for EAX12 and EX6250v2 series, and perhaps other devices. Compatibility is preserved with the WAX202 and WAX206. In addition, adds the related vars to DEVICE_VARS so that the variables work correctly with multiple devices. References in GPL source: https://www.downloads.netgear.com/files/GPL/EAX12_EAX11v2_EAX15v2_GPL_V1.0.3.34_src.tar.gz * tools/imgencoder/src/gj_enc.c Contains code that generates the encrypted image. Signed-off-by: Wenli Looi <wlooi@ucalgary.ca> (cherry picked from commit 0a1ebccc8702cadc50bc096f1e185472f3927786)
Diffstat (limited to 'target/linux/mediatek')
-rw-r--r--target/linux/mediatek/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/mediatek/image/Makefile b/target/linux/mediatek/image/Makefile
index 97164428e0..d4f79ec974 100644
--- a/target/linux/mediatek/image/Makefile
+++ b/target/linux/mediatek/image/Makefile
@@ -6,6 +6,8 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+DEVICE_VARS += NETGEAR_ENC_MODEL NETGEAR_ENC_REGION NETGEAR_ENC_HW_ID_LIST NETGEAR_ENC_MODEL_LIST
+
loadaddr-$(CONFIG_TARGET_mediatek_mt7622) := 0x44000000
loadaddr-$(CONFIG_TARGET_mediatek_mt7623) := 0x80008000
loadaddr-$(CONFIG_TARGET_mediatek_mt7629) := 0x40008000
@@ -22,6 +24,10 @@ define Device/Default
KERNEL_LOADADDR = $(loadaddr-y)
FILESYSTEMS := squashfs
DEVICE_DTS_DIR := $(DTS_DIR)
+ NETGEAR_ENC_MODEL :=
+ NETGEAR_ENC_REGION :=
+ NETGEAR_ENC_HW_ID_LIST :=
+ NETGEAR_ENC_MODEL_LIST :=
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin := append-kernel | pad-to 128k | append-rootfs | \
pad-rootfs | append-metadata