aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek
diff options
context:
space:
mode:
authorShiji Yang <yangshiji66@qq.com>2022-12-17 12:50:55 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2023-01-07 17:11:00 +0100
commit9a07895729a9701a673951a31ceb71f16f0a6fad (patch)
tree71fc9fc17fdd536bedeb53e78b05039a567bbe23 /target/linux/mediatek
parentfc9dd3f0834317ceb20700fd7033987695661097 (diff)
downloadupstream-9a07895729a9701a673951a31ceb71f16f0a6fad.tar.gz
upstream-9a07895729a9701a673951a31ceb71f16f0a6fad.tar.bz2
upstream-9a07895729a9701a673951a31ceb71f16f0a6fad.zip
mt76: add stand-alone MT7622 firmware package
Add a separate firmware package to avoid installing the MT7615 firmware on all MT7622 target devices by default. Now we only add MT7615 firmware packages for devices that use MT7615E. This commit also removes the explicit dependency on kmod-mt7615e to refine the package dependency. Signed-off-by: Shiji Yang <yangshiji66@qq.com>
Diffstat (limited to 'target/linux/mediatek')
-rw-r--r--target/linux/mediatek/image/mt7622.mk6
-rw-r--r--target/linux/mediatek/mt7622/target.mk2
2 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index d90207e464..097ddd6bfd 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -129,7 +129,7 @@ define Device/buffalo_wsr-2533dhp2
IMAGE/sysupgrade.bin := append-kernel | \
buffalo-kernel-trx 0x32504844 $(KDIR)/tmp/$$(DEVICE_NAME).null | \
sysupgrade-tar kernel=$$$$@ | append-metadata
- DEVICE_PACKAGES := swconfig
+ DEVICE_PACKAGES := kmod-mt7615-firmware swconfig
endef
TARGET_DEVICES += buffalo_wsr-2533dhp2
@@ -138,7 +138,7 @@ define Device/elecom_wrc-2533gent
DEVICE_MODEL := WRC-2533GENT
DEVICE_DTS := mt7622-elecom-wrc-2533gent
DEVICE_DTS_DIR := ../dts
- DEVICE_PACKAGES := kmod-btmtkuart kmod-usb3 swconfig
+ DEVICE_PACKAGES := kmod-btmtkuart kmod-mt7615-firmware kmod-usb3 swconfig
endef
TARGET_DEVICES += elecom_wrc-2533gent
@@ -251,7 +251,7 @@ define Device/totolink_a8000ru
DEVICE_MODEL := A8000RU
DEVICE_DTS := mt7622-totolink-a8000ru
DEVICE_DTS_DIR := ../dts
- DEVICE_PACKAGES := swconfig
+ DEVICE_PACKAGES := kmod-mt7615-firmware swconfig
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
endef
TARGET_DEVICES += totolink_a8000ru
diff --git a/target/linux/mediatek/mt7622/target.mk b/target/linux/mediatek/mt7622/target.mk
index 92c3f47370..7c9d57b6a1 100644
--- a/target/linux/mediatek/mt7622/target.mk
+++ b/target/linux/mediatek/mt7622/target.mk
@@ -2,7 +2,7 @@ ARCH:=aarch64
SUBTARGET:=mt7622
BOARDNAME:=MT7622
CPU_TYPE:=cortex-a53
-DEFAULT_PACKAGES += kmod-mt7615e kmod-mt7615-firmware wpad-basic-wolfssl uboot-envtools
+DEFAULT_PACKAGES += kmod-mt7622-firmware wpad-basic-wolfssl uboot-envtools
KERNELNAME:=Image dtbs
define Target/Description