aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2023-05-19 09:31:36 +0100
committerDaniel Golle <daniel@makrotopia.org>2023-05-19 09:34:22 +0100
commita384490b102c72b262b716ec746e75dc27f89727 (patch)
tree8d43905c0abe27e5f360fc99061eb6f59b7e1ad5 /target/linux/mediatek
parentcf19fd0cb59f6e91e87f74a5471ea92a751e91d0 (diff)
downloadupstream-a384490b102c72b262b716ec746e75dc27f89727.tar.gz
upstream-a384490b102c72b262b716ec746e75dc27f89727.tar.bz2
upstream-a384490b102c72b262b716ec746e75dc27f89727.zip
mediatek: fix append-gl-metadata when running in buildbot
Use same logic as in append-metadata so build doesn't fail in case of missing build-key (it was previously failing on the buildbot runners). Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/mediatek')
-rw-r--r--target/linux/mediatek/image/filogic.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/target/linux/mediatek/image/filogic.mk b/target/linux/mediatek/image/filogic.mk
index 5c8b47c662..7159917ff4 100644
--- a/target/linux/mediatek/image/filogic.mk
+++ b/target/linux/mediatek/image/filogic.mk
@@ -58,9 +58,12 @@ metadata_gl_json = \
define Build/append-gl-metadata
$(if $(SUPPORTED_DEVICES),-echo $(call metadata_gl_json,$(SUPPORTED_DEVICES)) | fwtool -I - $@)
- [ ! -s "$(BUILD_KEY)" -o ! -s "$@" ] || { \
+ sha256sum "$@" | cut -d" " -f1 > "$@.sha256sum"
+ [ ! -s "$(BUILD_KEY)" -o ! -s "$(BUILD_KEY).ucert" -o ! -s "$@" ] || { \
+ cp "$(BUILD_KEY).ucert" "$@.ucert" ;\
usign -S -m "$@" -s "$(BUILD_KEY)" -x "$@.sig" ;\
- fwtool -S "$@.sig" "$@" ;\
+ ucert -A -c "$@.ucert" -x "$@.sig" ;\
+ fwtool -S "$@.ucert" "$@" ;\
}
endef