aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-01-22 00:20:53 +0000
committerDaniel Golle <daniel@makrotopia.org>2022-01-23 19:48:07 +0000
commita40b4d335a19022745ef6d714f88e6b26615ad50 (patch)
treeba793567c3e04bfb71cc5db68eb326103e36a9cd /target/linux/mediatek
parent7edd10f9dfd9010ac899ed837ce1b7929e8b68f9 (diff)
downloadupstream-a40b4d335a19022745ef6d714f88e6b26615ad50.tar.gz
upstream-a40b4d335a19022745ef6d714f88e6b26615ad50.tar.bz2
upstream-a40b4d335a19022745ef6d714f88e6b26615ad50.zip
mediatek: use CONFIG_TARGET_ROOTFS_PARTSIZE
Enable 'rootfs-part' feature to make the size of the partition of the production image configurable instead of hard-coding it. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/mediatek')
-rw-r--r--target/linux/mediatek/Makefile2
-rw-r--r--target/linux/mediatek/image/mt7622.mk4
-rw-r--r--target/linux/mediatek/image/mt7623.mk4
3 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/mediatek/Makefile b/target/linux/mediatek/Makefile
index fb2951cc9b..466fe6dee2 100644
--- a/target/linux/mediatek/Makefile
+++ b/target/linux/mediatek/Makefile
@@ -6,7 +6,7 @@ ARCH:=arm
BOARD:=mediatek
BOARDNAME:=MediaTek Ralink ARM
SUBTARGETS:=mt7622 mt7623 mt7629
-FEATURES:=dt-overlay emmc fpu gpio nand pci pcie separate_ramdisk squashfs usb
+FEATURES:=dt-overlay emmc fpu gpio nand pci pcie rootfs-part separate_ramdisk squashfs usb
KERNEL_PATCHVER:=5.10
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index 3b0afa98df..3517748510 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -48,10 +48,10 @@ define Build/mt7622-gpt
-N recovery -r -p 32M@6M \
$(if $(findstring sdmmc,$1), \
-N install -r -p 7M@38M \
- -t 0x2e -N production -p 211M@45M \
+ -t 0x2e -N production -p $(CONFIG_TARGET_ROOTFS_PARTSIZE)M@45M \
) \
$(if $(findstring emmc,$1), \
- -t 0x2e -N production -p 980M@40M \
+ -t 0x2e -N production -p $(CONFIG_TARGET_ROOTFS_PARTSIZE)M@40M \
)
cat $@.tmp >> $@
rm $@.tmp
diff --git a/target/linux/mediatek/image/mt7623.mk b/target/linux/mediatek/image/mt7623.mk
index 9a938662c3..1d7745f1d6 100644
--- a/target/linux/mediatek/image/mt7623.mk
+++ b/target/linux/mediatek/image/mt7623.mk
@@ -58,10 +58,10 @@ define Build/mt7623-mbr
-t 0x41 -N uboot -p 3584k@320k \
-t 0xea -N recovery -p 40M@4M \
$(if $(findstring sdmmc,$1), \
- -t 0x2e -N production -p 208M@48M \
+ -t 0x2e -N production -p $(CONFIG_TARGET_ROOTFS_PARTSIZE)M@48M \
) \
$(if $(findstring emmc,$1), \
- -t 0x2e -N production -p 976M@48M \
+ -t 0x2e -N production -p $(CONFIG_TARGET_ROOTFS_PARTSIZE)M@48M \
)
echo -en \