aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2018-06-27 22:21:57 +0200
committerJohn Crispin <john@phrozen.org>2018-07-02 07:04:48 +0200
commitf4ac88b5097685950c6f6ba0077840f85446389f (patch)
treee59cf8cc6d784d5110d14d0faa57d266c63a88e7 /target/linux/mediatek
parent8e622aae583904a87f358535294bbe5e0088ef8c (diff)
downloadupstream-f4ac88b5097685950c6f6ba0077840f85446389f.tar.gz
upstream-f4ac88b5097685950c6f6ba0077840f85446389f.tar.bz2
upstream-f4ac88b5097685950c6f6ba0077840f85446389f.zip
kernel: bump 4.14 to 4.14.52
Refreshed all patches Compile-tested on: cns3xxx, imx6, x86_64 Runtime-tested on: cns3xxx, imx6, x86_64 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/mediatek')
-rw-r--r--target/linux/mediatek/patches-4.14/0225-arm-dts-Add-missing-mt7623-pcie-nodes.patch7
-rw-r--r--target/linux/mediatek/patches-4.14/0226-phy-phy-mtk-tphy-Add-hifsys-support.patch17
-rw-r--r--target/linux/mediatek/patches-4.14/0227-arm-dts-Add-Unielec-U7623-DTS.patch11
3 files changed, 7 insertions, 28 deletions
diff --git a/target/linux/mediatek/patches-4.14/0225-arm-dts-Add-missing-mt7623-pcie-nodes.patch b/target/linux/mediatek/patches-4.14/0225-arm-dts-Add-missing-mt7623-pcie-nodes.patch
index b87f95c1f9..6e94015dc5 100644
--- a/target/linux/mediatek/patches-4.14/0225-arm-dts-Add-missing-mt7623-pcie-nodes.patch
+++ b/target/linux/mediatek/patches-4.14/0225-arm-dts-Add-missing-mt7623-pcie-nodes.patch
@@ -7,11 +7,9 @@ Subject: [PATCH] arm: dts: Add missing mt7623 pcie nodes
arch/arm/boot/dts/mt7623.dtsi | 105 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 105 insertions(+)
-diff --git a/arch/arm/boot/dts/mt7623.dtsi b/arch/arm/boot/dts/mt7623.dtsi
-index 36983a7d7..714245365 100644
--- a/arch/arm/boot/dts/mt7623.dtsi
+++ b/arch/arm/boot/dts/mt7623.dtsi
-@@ -669,6 +669,111 @@
+@@ -670,6 +670,111 @@
#reset-cells = <1>;
};
@@ -123,6 +121,3 @@ index 36983a7d7..714245365 100644
usb1: usb@1a1c0000 {
compatible = "mediatek,mt7623-xhci",
"mediatek,mt8173-xhci";
---
-2.14.1
-
diff --git a/target/linux/mediatek/patches-4.14/0226-phy-phy-mtk-tphy-Add-hifsys-support.patch b/target/linux/mediatek/patches-4.14/0226-phy-phy-mtk-tphy-Add-hifsys-support.patch
index 1ac15bdb72..b480e9b4ca 100644
--- a/target/linux/mediatek/patches-4.14/0226-phy-phy-mtk-tphy-Add-hifsys-support.patch
+++ b/target/linux/mediatek/patches-4.14/0226-phy-phy-mtk-tphy-Add-hifsys-support.patch
@@ -7,12 +7,10 @@ Subject: [PATCH] phy: phy-mtk-tphy: Add hifsys-support
drivers/phy/mediatek/phy-mtk-tphy.c | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)
-diff --git a/drivers/phy/mediatek/phy-mtk-tphy.c b/drivers/phy/mediatek/phy-mtk-tphy.c
-index 721a2a1c9..0cb1cea53 100644
--- a/drivers/phy/mediatek/phy-mtk-tphy.c
+++ b/drivers/phy/mediatek/phy-mtk-tphy.c
-@@ -22,6 +22,8 @@
- #include <linux/of_address.h>
+@@ -23,6 +23,8 @@
+ #include <linux/of_device.h>
#include <linux/phy/phy.h>
#include <linux/platform_device.h>
+#include <linux/mfd/syscon.h>
@@ -20,7 +18,7 @@ index 721a2a1c9..0cb1cea53 100644
/* version V1 sub-banks offset base address */
/* banks shared by multiple phys */
-@@ -259,6 +261,9 @@
+@@ -262,6 +264,9 @@
#define RG_CDR_BIRLTD0_GEN3_MSK GENMASK(4, 0)
#define RG_CDR_BIRLTD0_GEN3_VAL(x) (0x1f & (x))
@@ -30,7 +28,7 @@ index 721a2a1c9..0cb1cea53 100644
enum mtk_phy_version {
MTK_PHY_V1 = 1,
MTK_PHY_V2,
-@@ -302,6 +307,7 @@ struct mtk_tphy {
+@@ -305,6 +310,7 @@ struct mtk_tphy {
struct clk *u3phya_ref; /* reference clock of usb3 anolog phy */
const struct mtk_phy_pdata *pdata;
struct mtk_phy_instance **phys;
@@ -38,7 +36,7 @@ index 721a2a1c9..0cb1cea53 100644
int nphys;
};
-@@ -594,6 +600,10 @@ static void pcie_phy_instance_init(struct mtk_tphy *tphy,
+@@ -617,6 +623,10 @@ static void pcie_phy_instance_init(struc
if (tphy->pdata->version != MTK_PHY_V1)
return;
@@ -49,7 +47,7 @@ index 721a2a1c9..0cb1cea53 100644
tmp = readl(u3_banks->phya + U3P_U3_PHYA_DA_REG0);
tmp &= ~(P3A_RG_XTAL_EXT_PE1H | P3A_RG_XTAL_EXT_PE2H);
tmp |= P3A_RG_XTAL_EXT_PE1H_VAL(0x2) | P3A_RG_XTAL_EXT_PE2H_VAL(0x2);
-@@ -1008,6 +1018,16 @@ static int mtk_tphy_probe(struct platform_device *pdev)
+@@ -1042,6 +1052,16 @@ static int mtk_tphy_probe(struct platfor
tphy->u3phya_ref = NULL;
}
@@ -66,6 +64,3 @@ index 721a2a1c9..0cb1cea53 100644
port = 0;
for_each_child_of_node(np, child_np) {
struct mtk_phy_instance *instance;
---
-2.14.1
-
diff --git a/target/linux/mediatek/patches-4.14/0227-arm-dts-Add-Unielec-U7623-DTS.patch b/target/linux/mediatek/patches-4.14/0227-arm-dts-Add-Unielec-U7623-DTS.patch
index 9d554da0be..f4a21d4f64 100644
--- a/target/linux/mediatek/patches-4.14/0227-arm-dts-Add-Unielec-U7623-DTS.patch
+++ b/target/linux/mediatek/patches-4.14/0227-arm-dts-Add-Unielec-U7623-DTS.patch
@@ -11,8 +11,6 @@ Subject: [PATCH] arm: dts: Add Unielec U7623 DTS
create mode 100644 arch/arm/boot/dts/mt7623a-unielec-u7623-02-emmc-512M.dts
create mode 100644 arch/arm/boot/dts/mt7623a-unielec-u7623-02-emmc.dtsi
-diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
-index 3fec84fa0..e685ce9a4 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -1062,6 +1062,7 @@ dtb-$(CONFIG_ARCH_MEDIATEK) += \
@@ -23,9 +21,6 @@ index 3fec84fa0..e685ce9a4 100644
mt7623n-rfb-nand.dtb \
mt7623n-bananapi-bpi-r2.dtb \
mt8127-moose.dtb \
-diff --git a/arch/arm/boot/dts/mt7623a-unielec-u7623-02-emmc-512M.dts b/arch/arm/boot/dts/mt7623a-unielec-u7623-02-emmc-512M.dts
-new file mode 100644
-index 000000000..3b14eccd3
--- /dev/null
+++ b/arch/arm/boot/dts/mt7623a-unielec-u7623-02-emmc-512M.dts
@@ -0,0 +1,17 @@
@@ -46,9 +41,6 @@ index 000000000..3b14eccd3
+ reg = <0 0x80000000 0 0x20000000>;
+ };
+};
-diff --git a/arch/arm/boot/dts/mt7623a-unielec-u7623-02-emmc.dtsi b/arch/arm/boot/dts/mt7623a-unielec-u7623-02-emmc.dtsi
-new file mode 100644
-index 000000000..4fc8ce8a9
--- /dev/null
+++ b/arch/arm/boot/dts/mt7623a-unielec-u7623-02-emmc.dtsi
@@ -0,0 +1,374 @@
@@ -426,6 +418,3 @@ index 000000000..4fc8ce8a9
+ status = "okay";
+};
+
---
-2.14.1
-