aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/patches/0030-I2C-mediatek-Add-driver-for-MediaTek-I2C-controller.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2015-12-02 21:52:41 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2015-12-02 21:52:41 +0000
commitf0a5f24217fbedd7ffba0a2a0bf37c1102e44ad0 (patch)
treef4e3850683bbb922227f58993e41a4784a670932 /target/linux/mediatek/patches/0030-I2C-mediatek-Add-driver-for-MediaTek-I2C-controller.patch
parent40a09b93d274737c704165f687149b4956fbd45c (diff)
downloadupstream-f0a5f24217fbedd7ffba0a2a0bf37c1102e44ad0.tar.gz
upstream-f0a5f24217fbedd7ffba0a2a0bf37c1102e44ad0.tar.bz2
upstream-f0a5f24217fbedd7ffba0a2a0bf37c1102e44ad0.zip
kernel: update 4.1 to 4.1.13
- two upstreamed patches removed - compile tested all targets using 4.1 - run tested ar71xx Signed-off-by: Roman Yeryomin <roman@advem.lv> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 47694
Diffstat (limited to 'target/linux/mediatek/patches/0030-I2C-mediatek-Add-driver-for-MediaTek-I2C-controller.patch')
-rw-r--r--target/linux/mediatek/patches/0030-I2C-mediatek-Add-driver-for-MediaTek-I2C-controller.patch10
1 files changed, 0 insertions, 10 deletions
diff --git a/target/linux/mediatek/patches/0030-I2C-mediatek-Add-driver-for-MediaTek-I2C-controller.patch b/target/linux/mediatek/patches/0030-I2C-mediatek-Add-driver-for-MediaTek-I2C-controller.patch
index df22f08764..f7048f1668 100644
--- a/target/linux/mediatek/patches/0030-I2C-mediatek-Add-driver-for-MediaTek-I2C-controller.patch
+++ b/target/linux/mediatek/patches/0030-I2C-mediatek-Add-driver-for-MediaTek-I2C-controller.patch
@@ -17,8 +17,6 @@ Signed-off-by: Eddie Huang <eddie.huang@mediatek.com>
3 files changed, 710 insertions(+)
create mode 100644 drivers/i2c/busses/i2c-mt65xx.c
-diff --git a/drivers/i2c/busses/Kconfig b/drivers/i2c/busses/Kconfig
-index 2255af2..14c7266 100644
--- a/drivers/i2c/busses/Kconfig
+++ b/drivers/i2c/busses/Kconfig
@@ -620,6 +620,15 @@ config I2C_MPC
@@ -37,8 +35,6 @@ index 2255af2..14c7266 100644
config I2C_MV64XXX
tristate "Marvell mv64xxx I2C Controller"
depends on MV64X60 || PLAT_ORION || ARCH_SUNXI
-diff --git a/drivers/i2c/busses/Makefile b/drivers/i2c/busses/Makefile
-index cdf941d..abbf422 100644
--- a/drivers/i2c/busses/Makefile
+++ b/drivers/i2c/busses/Makefile
@@ -60,6 +60,7 @@ obj-$(CONFIG_I2C_JZ4780) += i2c-jz4780.o
@@ -49,9 +45,6 @@ index cdf941d..abbf422 100644
obj-$(CONFIG_I2C_MV64XXX) += i2c-mv64xxx.o
obj-$(CONFIG_I2C_MXS) += i2c-mxs.o
obj-$(CONFIG_I2C_NOMADIK) += i2c-nomadik.o
-diff --git a/drivers/i2c/busses/i2c-mt65xx.c b/drivers/i2c/busses/i2c-mt65xx.c
-new file mode 100644
-index 0000000..faecf7e
--- /dev/null
+++ b/drivers/i2c/busses/i2c-mt65xx.c
@@ -0,0 +1,700 @@
@@ -755,6 +748,3 @@ index 0000000..faecf7e
+MODULE_LICENSE("GPL v2");
+MODULE_DESCRIPTION("MediaTek I2C Bus Driver");
+MODULE_AUTHOR("Xudong Chen <xudong.chen@mediatek.com>");
---
-1.7.10.4
-