aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/patches-5.4/0990-gsw-rtl8367s-mt7622-support.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2020-04-03 17:42:44 +0200
committerJohn Crispin <john@phrozen.org>2020-04-06 07:07:42 +0200
commitaf5a17dbb268b79be6fa9ae16a330bd7303ee843 (patch)
treefd6261bf9902d37e3cd51e4d3ad0c56ead85d060 /target/linux/mediatek/patches-5.4/0990-gsw-rtl8367s-mt7622-support.patch
parent08df22e2abf053e2d5ddef6393fe26b277fa7d18 (diff)
downloadupstream-af5a17dbb268b79be6fa9ae16a330bd7303ee843.tar.gz
upstream-af5a17dbb268b79be6fa9ae16a330bd7303ee843.tar.bz2
upstream-af5a17dbb268b79be6fa9ae16a330bd7303ee843.zip
mediatek: add support for rtl8367c
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/mediatek/patches-5.4/0990-gsw-rtl8367s-mt7622-support.patch')
-rw-r--r--target/linux/mediatek/patches-5.4/0990-gsw-rtl8367s-mt7622-support.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/mediatek/patches-5.4/0990-gsw-rtl8367s-mt7622-support.patch b/target/linux/mediatek/patches-5.4/0990-gsw-rtl8367s-mt7622-support.patch
new file mode 100644
index 0000000000..62f47115d6
--- /dev/null
+++ b/target/linux/mediatek/patches-5.4/0990-gsw-rtl8367s-mt7622-support.patch
@@ -0,0 +1,27 @@
+Index: linux-4.19.88/drivers/net/phy/Kconfig
+===================================================================
+--- linux-4.19.88.orig/drivers/net/phy/Kconfig
++++ linux-4.19.88/drivers/net/phy/Kconfig
+@@ -26,6 +26,12 @@ config MDIO_BCM_IPROC
+ This module provides a driver for the MDIO busses found in the
+ Broadcom iProc SoC's.
+
++config RTL8367S_GSW
++ tristate "rtl8367 Gigabit Switch support for mt7622"
++ depends on NET_VENDOR_MEDIATEK
++ help
++ This driver supports rtl8367s in mt7622
++
+ config MDIO_BCM_UNIMAC
+ tristate "Broadcom UniMAC MDIO bus controller"
+ depends on HAS_IOMEM
+Index: linux-4.19.88/drivers/net/phy/Makefile
+===================================================================
+--- linux-4.19.88.orig/drivers/net/phy/Makefile
++++ linux-4.19.88/drivers/net/phy/Makefile
+@@ -101,4 +101,5 @@ obj-$(CONFIG_TERANETICS_PHY) += teraneti
+ obj-$(CONFIG_VITESSE_PHY) += vitesse.o
+ obj-$(CONFIG_XILINX_GMII2RGMII) += xilinx_gmii2rgmii.o
+ obj-$(CONFIG_MT753X_GSW) += mtk/mt753x/
++obj-$(CONFIG_RTL8367S_GSW) += rtk/
+