aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/mt7629/profiles
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2019-11-01 11:17:28 +0800
committerChuanhong Guo <gch981213@gmail.com>2019-11-04 20:51:19 +0800
commit09fe0c847dd32a829fd3dcb21e284cc0c7a3e763 (patch)
tree54cf3c29b96e19d1754732b45b7b3160bb8f8285 /target/linux/mediatek/mt7629/profiles
parent58b0d3ecd66ef220101d1f4dfe550242d6004fce (diff)
downloadupstream-09fe0c847dd32a829fd3dcb21e284cc0c7a3e763.tar.gz
upstream-09fe0c847dd32a829fd3dcb21e284cc0c7a3e763.tar.bz2
upstream-09fe0c847dd32a829fd3dcb21e284cc0c7a3e763.zip
mediatek: add mt7629 subtarget with rfb image
base-files are added into subtarget directory like what's done recently in ath79. For this subtarget, metadata checks are enforced and a SUPPORTED_DEVICE is added to generate proper metadata. Since we only have mt7629 support in 4.19, override KERNEL_PATCHVER in target.mk for now. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/mediatek/mt7629/profiles')
-rw-r--r--target/linux/mediatek/mt7629/profiles/default.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/mediatek/mt7629/profiles/default.mk b/target/linux/mediatek/mt7629/profiles/default.mk
new file mode 100644
index 0000000000..2ef570ba66
--- /dev/null
+++ b/target/linux/mediatek/mt7629/profiles/default.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile (minimum package set)
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))