aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/mt7623/target.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-11-12 11:50:26 +0000
committerDaniel Golle <daniel@makrotopia.org>2021-11-12 15:03:02 +0000
commitc3c67fe7b1fbfc9b08e1a2d056b120aa63ef4145 (patch)
tree2f0af24b485efd8741a6cf676d52c0cacfc5f73b /target/linux/mediatek/mt7623/target.mk
parent0cbc6b16db8ce03a522b9acb49ea46cc2134697a (diff)
downloadupstream-c3c67fe7b1fbfc9b08e1a2d056b120aa63ef4145.tar.gz
upstream-c3c67fe7b1fbfc9b08e1a2d056b120aa63ef4145.tar.bz2
upstream-c3c67fe7b1fbfc9b08e1a2d056b120aa63ef4145.zip
mediatek: mt7623: re-write sysupgrade uImage.FIT on MMC
Re-reading the partition table doesn't work reliably, it fails if anything on the device is still in use and it's not trivial to prevent every possible case of a block device still being in use somehow. Therefore, instead of relying on the in-kernel partition parser to know where to write the configuration backup, use OpenWrt's format-agnostic fwtool to strip off all metadata from the image and count its blocks while writing. In that way we can know where to write the config backup without needing the kernel to parse the MBR and FIT structures. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/mediatek/mt7623/target.mk')
-rw-r--r--target/linux/mediatek/mt7623/target.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/mediatek/mt7623/target.mk b/target/linux/mediatek/mt7623/target.mk
index ad05367f86..cc5ff3f27d 100644
--- a/target/linux/mediatek/mt7623/target.mk
+++ b/target/linux/mediatek/mt7623/target.mk
@@ -9,7 +9,7 @@ CPU_TYPE:=cortex-a7
CPU_SUBTYPE:=neon-vfpv4
KERNELNAME:=Image dtbs zImage
FEATURES+=display usbgadget
-DEFAULT_PACKAGES+=blockdev uboot-envtools
+DEFAULT_PACKAGES+=uboot-envtools
define Target/Description
Build firmware images for MediaTek mt7623 ARM based boards.