aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/modules.mk
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2022-04-30 23:08:00 +0800
committerDaniel Golle <daniel@makrotopia.org>2022-07-04 19:57:49 +0100
commit1d96f6863e335956838e1002241a018affdaa287 (patch)
treef30f1c8fc29e8a9d0b05d7be921ae3ab576d9f6b /target/linux/mediatek/modules.mk
parent2bea35cb55d769ab1fdf497baa1c6c3261a33ca4 (diff)
downloadupstream-1d96f6863e335956838e1002241a018affdaa287.tar.gz
upstream-1d96f6863e335956838e1002241a018affdaa287.tar.bz2
upstream-1d96f6863e335956838e1002241a018affdaa287.zip
mediatek: build ubnt-ledbar as a module
The config for LEDS_UBNT_LEDBAR doesn't stay in mt7629 kconfig because of its I2C dependency. Build it as a module and let buildroot handle this config option instead. Signed-off-by: Chuanhong Guo <gch981213@gmail.com> (cherry picked from commit d9ea9c06e98b597174e0e94e0a13934637c0c03e)
Diffstat (limited to 'target/linux/mediatek/modules.mk')
-rw-r--r--target/linux/mediatek/modules.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/mediatek/modules.mk b/target/linux/mediatek/modules.mk
index 467934256c..0eb2866cf0 100644
--- a/target/linux/mediatek/modules.mk
+++ b/target/linux/mediatek/modules.mk
@@ -38,3 +38,19 @@ define KernelPackage/sdhci-mtk
endef
$(eval $(call KernelPackage,sdhci-mtk))
+
+define KernelPackage/leds-ubnt-ledbar
+ SUBMENU:=LED modules
+ TITLE:=Ubiquiti UniFi 6 LR LED support
+ KCONFIG:=CONFIG_LEDS_UBNT_LEDBAR
+ FILES:= \
+ $(LINUX_DIR)/drivers/leds/leds-ubnt-ledbar.ko
+ AUTOLOAD:=$(call AutoProbe,leds-ubnt-ledbar,1)
+ DEPENDS:=@TARGET_mediatek_mt7622 +kmod-i2c-core
+endef
+
+define KernelPackage/leds-ubnt-ledbar/description
+ LED support for Ubiquiti UniFi 6 LR
+endef
+
+$(eval $(call KernelPackage,leds-ubnt-ledbar))