aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/modules.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-10-19 23:03:07 +0100
committerDaniel Golle <daniel@makrotopia.org>2022-10-19 23:20:48 +0100
commitf2ae4e2f8cf698f6fc6ae802dae86f50916f4286 (patch)
tree802329cdd79e48f8b4a0f07670015cf11862feb4 /target/linux/mediatek/modules.mk
parente57ca876cca2a626cd62d16d677a013e61d18160 (diff)
downloadupstream-f2ae4e2f8cf698f6fc6ae802dae86f50916f4286.tar.gz
upstream-f2ae4e2f8cf698f6fc6ae802dae86f50916f4286.tar.bz2
upstream-f2ae4e2f8cf698f6fc6ae802dae86f50916f4286.zip
mediatek: clean up platform kernel modules
Remove kmod-sdhci-mtk as the mtk-sd driver is built-in anyway for the relevant subtargets in order to support mounting rootfs from eMMC or SD card. Add kmod-iio-mt6577-auxadc to support reading the raw values from the auxadc unit used as in-SoC thermal sensor. This driver was previously built-in, but as thermal itself works well without it there is no use for it in every day use of a device. Build the module to still allow access to the raw values for those who need it. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/mediatek/modules.mk')
-rw-r--r--target/linux/mediatek/modules.mk19
1 files changed, 8 insertions, 11 deletions
diff --git a/target/linux/mediatek/modules.mk b/target/linux/mediatek/modules.mk
index 42f2d7d832..f46a6ad2ff 100644
--- a/target/linux/mediatek/modules.mk
+++ b/target/linux/mediatek/modules.mk
@@ -27,16 +27,13 @@ endef
$(eval $(call KernelPackage,btmtkuart))
-define KernelPackage/sdhci-mtk
- SUBMENU:=Other modules
- TITLE:=Mediatek SDHCI driver
- DEPENDS:=@TARGET_mediatek_mt7622 +kmod-sdhci
- KCONFIG:=CONFIG_MMC_MTK
+define KernelPackage/iio-mt6577-auxadc
+ TITLE:=Mediatek AUXADC driver
+ DEPENDS:=@(TARGET_mediatek_mt7622||TARGET_mediatek_mt7623||TARGET_mediatek_filogic)
+ KCONFIG:=CONFIG_MEDIATEK_MT6577_AUXADC
FILES:= \
- $(LINUX_DIR)/drivers/mmc/host/mtk-sd.ko
- AUTOLOAD:=$(call AutoProbe,mtk-sd,1)
+ $(LINUX_DIR)/drivers/iio/adc/mt6577_auxadc.ko
+ AUTOLOAD:=$(call AutoProbe,mt6577_auxadc)
+ $(call AddDepends/iio)
endef
-
-$(eval $(call KernelPackage,sdhci-mtk))
-
-
+$(eval $(call KernelPackage,iio-mt6577-auxadc))