aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/modules.mk
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2020-09-22 21:04:02 +0800
committerChuanhong Guo <gch981213@gmail.com>2020-09-22 21:07:50 +0800
commit20f2bd044a56f32e9e0782745558858f21bb550f (patch)
treebd1f020bd4b077c34fdcb523168b8e5e3b39a75a /target/linux/mediatek/modules.mk
parentd643b10a76965a94684012d2ddf36e2bcc146274 (diff)
downloadupstream-20f2bd044a56f32e9e0782745558858f21bb550f.tar.gz
upstream-20f2bd044a56f32e9e0782745558858f21bb550f.tar.bz2
upstream-20f2bd044a56f32e9e0782745558858f21bb550f.zip
mediatek: build btmtkuart as a kernel module
bluetooth on mt7622 needs a firmware to start. It can't be built-in or it tries to load firmware before rootfs is mounted, and then fails. build it as a kernel module to fix that. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/mediatek/modules.mk')
-rw-r--r--target/linux/mediatek/modules.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/mediatek/modules.mk b/target/linux/mediatek/modules.mk
index eb81afe235..9c6fb515f4 100644
--- a/target/linux/mediatek/modules.mk
+++ b/target/linux/mediatek/modules.mk
@@ -15,6 +15,18 @@ endef
$(eval $(call KernelPackage,ata-ahci-mtk))
+define KernelPackage/btmtkuart
+ SUBMENU:=Other modules
+ TITLE:=MediaTek HCI UART driver
+ DEPENDS:=@TARGET_mediatek_mt7622 +kmod-bluetooth +mt7622bt-firmware
+ KCONFIG:=CONFIG_BT_MTKUART
+ FILES:= \
+ $(LINUX_DIR)/drivers/bluetooth/btmtkuart.ko
+ AUTOLOAD:=$(call AutoProbe,btmtkuart)
+endef
+
+$(eval $(call KernelPackage,btmtkuart))
+
define KernelPackage/sdhci-mtk
SUBMENU:=Other modules
TITLE:=Mediatek SDHCI driver