aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2022-05-31 19:18:06 +0200
committerDaniel Golle <daniel@makrotopia.org>2022-07-04 19:57:54 +0100
commit8f0d8869d536f1a9c1dce25f37753900d253df3c (patch)
treef833ff8b1c4f4a3577c24f45184fb906cdba05f0 /target/linux/mediatek/image
parent1d96f6863e335956838e1002241a018affdaa287 (diff)
downloadupstream-8f0d8869d536f1a9c1dce25f37753900d253df3c.tar.gz
upstream-8f0d8869d536f1a9c1dce25f37753900d253df3c.tar.bz2
upstream-8f0d8869d536f1a9c1dce25f37753900d253df3c.zip
mediatek: new target mt7622-ubnt-unifi-6-lr-v1
Based on current mt7622-ubnt-unifi-6-lr, this is a preparation for adding a v2 version of this target * v1 - with led-bar * v2 - two simple GPIO connected LEDs (in later commits) Signed-off-by: Daniel Golle <daniel@makrotopia.org> [added SUPPORTED_DEVICES for compatibility with existing setups] Signed-off-by: Henrik Riomar <henrik.riomar@gmail.com> (cherry picked from commit 15a02471bb854245f8f94398c1e1d9ce29c2c341)
Diffstat (limited to 'target/linux/mediatek/image')
-rw-r--r--target/linux/mediatek/image/mt7622.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index 39bc7bc2ea..ea5ebdd410 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -222,15 +222,17 @@ define Device/totolink_a8000ru
endef
TARGET_DEVICES += totolink_a8000ru
-define Device/ubnt_unifi-6-lr
+define Device/ubnt_unifi-6-lr-v1
DEVICE_VENDOR := Ubiquiti
DEVICE_MODEL := UniFi 6 LR
+ DEVICE_VARIANT := v1
DEVICE_DTS_CONFIG := config@1
- DEVICE_DTS := mt7622-ubnt-unifi-6-lr
+ DEVICE_DTS := mt7622-ubnt-unifi-6-lr-v1
DEVICE_DTS_DIR := ../dts
DEVICE_PACKAGES := kmod-mt7915e kmod-leds-ubnt-ledbar
+ SUPPORTED_DEVICES += ubnt,unifi-6-lr
endef
-TARGET_DEVICES += ubnt_unifi-6-lr
+TARGET_DEVICES += ubnt_unifi-6-lr-v1
define Device/ubnt_unifi-6-lr-ubootmod
DEVICE_VENDOR := Ubiquiti