aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/mt7623.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2023-04-05 16:56:54 +0100
committerDaniel Golle <daniel@makrotopia.org>2023-04-05 17:12:55 +0100
commite92b153e99a8019752b08c6ab0f7c17d9f08063e (patch)
treef5ee696d2ae83e5d719b9c05251add60bd537f0c /target/linux/mediatek/image/mt7623.mk
parent0dc5fc8fa53be55c3adc59055e7f6f150a5ab1ad (diff)
downloadupstream-e92b153e99a8019752b08c6ab0f7c17d9f08063e.tar.gz
upstream-e92b153e99a8019752b08c6ab0f7c17d9f08063e.tar.bz2
upstream-e92b153e99a8019752b08c6ab0f7c17d9f08063e.zip
mediatek: introduce KERNEL_LOADADDR to Device/Default template
We need to reset KERNEL_LOADADDR if we use it on a per-device base. Otherwise the previous value will be kept in case a device doesn't define KERNEL_LOADADDR and relies on the default. Move initializing KERNEL_LOADADDR to target/linux/mediatek/image/Makefile, similar to how it's done also on the ramips target. This fixes image size related breakage on devices which rely on the default value of KERNEL_LOADADDR. While at it use 0x48000000 which is more common than the previous default 0x44000000 for the filogic subtarget. Fixed: e7c399bee6 ("filogic: add support for ASUS TUF-AX4200") Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/mediatek/image/mt7623.mk')
-rw-r--r--target/linux/mediatek/image/mt7623.mk1
1 files changed, 0 insertions, 1 deletions
diff --git a/target/linux/mediatek/image/mt7623.mk b/target/linux/mediatek/image/mt7623.mk
index 4ef0aabe4d..26befc1c1e 100644
--- a/target/linux/mediatek/image/mt7623.mk
+++ b/target/linux/mediatek/image/mt7623.mk
@@ -1,4 +1,3 @@
-KERNEL_LOADADDR := 0x80008000
DEVICE_VARS += UBOOT_TARGET UBOOT_OFFSET UBOOT_IMAGE
# The bootrom of MT7623 expects legacy MediaTek headers present in