aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/mt7623.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-14 15:38:51 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-26 22:11:48 +0100
commit49d66e0468c14d8a05bd6c33056708d2051437cb (patch)
tree22a677bca7f12a43af7debb9ebb1bc3aba868d9c /target/linux/mediatek/image/mt7623.mk
parent9e0aab44b656be530b7b92ac03588ffc4d4cd1fa (diff)
downloadupstream-49d66e0468c14d8a05bd6c33056708d2051437cb.tar.gz
upstream-49d66e0468c14d8a05bd6c33056708d2051437cb.tar.bz2
upstream-49d66e0468c14d8a05bd6c33056708d2051437cb.zip
mediatek: use consistent naming scheme for device nodes
This harmonizes the device node names (and thus the image names, too) between subtargets of the mediatek target. So far, each subtarget has somewhat used its own naming scheme. Now, we use the vendor_device syntax there, too. Since DTS names have different patterns and the target only contains a few devices, this does not replace DEVICE_DTS by a calculated default value (like for other targets). SUPPORTED_DEVICES is adjusted based on the node rename where necessary, though it looks like for several older devices it was not set up correctly so far. While at it, this also changes the DTS name for u7623-02-emmc-512m to all-lower-case. Cc: John Crispin <john@phrozen.org> Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/mediatek/image/mt7623.mk')
-rw-r--r--target/linux/mediatek/image/mt7623.mk14
1 files changed, 6 insertions, 8 deletions
diff --git a/target/linux/mediatek/image/mt7623.mk b/target/linux/mediatek/image/mt7623.mk
index 3f72979849..fd609d22fa 100644
--- a/target/linux/mediatek/image/mt7623.mk
+++ b/target/linux/mediatek/image/mt7623.mk
@@ -1,20 +1,18 @@
-define Device/7623a-unielec-u7623-02-emmc-512m
+define Device/unielec_u7623-02-emmc-512m
DEVICE_VENDOR := UniElec
DEVICE_MODEL := U7623-02
DEVICE_VARIANT := eMMC/512MB RAM
- DEVICE_DTS := mt7623a-unielec-u7623-02-emmc-512M
+ DEVICE_DTS := mt7623a-unielec-u7623-02-emmc-512m
DEVICE_PACKAGES := mkf2fs e2fsprogs kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 kmod-mmc
- SUPPORTED_DEVICES := unielec,u7623-02-emmc-512m
IMAGES := sysupgrade-emmc.bin.gz
IMAGE/sysupgrade-emmc.bin.gz := sysupgrade-emmc | gzip | append-metadata
endef
+TARGET_DEVICES += unielec_u7623-02-emmc-512m
-TARGET_DEVICES += 7623a-unielec-u7623-02-emmc-512m
-
-define Device/7623n-bananapi-bpi-r2
+define Device/lemaker_bananapi-bpi-r2
DEVICE_VENDOR := LeMaker
DEVICE_MODEL := Banana Pi R2
DEVICE_DTS := mt7623n-bananapi-bpi-r2
+ SUPPORTED_DEVICES := bananapi,bpi-r2
endef
-
-TARGET_DEVICES += 7623n-bananapi-bpi-r2
+TARGET_DEVICES += lemaker_bananapi-bpi-r2