aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/mt7622.mk
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2022-04-30 23:08:00 +0800
committerChuanhong Guo <gch981213@gmail.com>2022-04-30 23:13:33 +0800
commitd9ea9c06e98b597174e0e94e0a13934637c0c03e (patch)
tree42af9b0dba6b4ae48b2dd06c003c6b1e137183af /target/linux/mediatek/image/mt7622.mk
parentdcf7285b713e6e6633d7cbc71a9090ae27771e0f (diff)
downloadupstream-d9ea9c06e98b597174e0e94e0a13934637c0c03e.tar.gz
upstream-d9ea9c06e98b597174e0e94e0a13934637c0c03e.tar.bz2
upstream-d9ea9c06e98b597174e0e94e0a13934637c0c03e.zip
mediatek: build ubnt-ledbar as a module
The config for LEDS_UBNT_LEDBAR doesn't stay in mt7629 kconfig because of its I2C dependency. Build it as a module and let buildroot handle this config option instead. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/mediatek/image/mt7622.mk')
-rw-r--r--target/linux/mediatek/image/mt7622.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index 8e0126f576..39bc7bc2ea 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -228,7 +228,7 @@ define Device/ubnt_unifi-6-lr
DEVICE_DTS_CONFIG := config@1
DEVICE_DTS := mt7622-ubnt-unifi-6-lr
DEVICE_DTS_DIR := ../dts
- DEVICE_PACKAGES := kmod-mt7915e
+ DEVICE_PACKAGES := kmod-mt7915e kmod-leds-ubnt-ledbar
endef
TARGET_DEVICES += ubnt_unifi-6-lr
@@ -238,7 +238,7 @@ define Device/ubnt_unifi-6-lr-ubootmod
DEVICE_VARIANT := U-Boot mod
DEVICE_DTS := mt7622-ubnt-unifi-6-lr-ubootmod
DEVICE_DTS_DIR := ../dts
- DEVICE_PACKAGES := kmod-mt7915e
+ DEVICE_PACKAGES := kmod-mt7915e kmod-leds-ubnt-ledbar
KERNEL := kernel-bin | lzma
KERNEL_INITRAMFS_SUFFIX := -recovery.itb
KERNEL_INITRAMFS := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb with-initrd | pad-to 64k