aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/mt7622.mk
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2022-04-30 23:08:00 +0800
committerDaniel Golle <daniel@makrotopia.org>2022-07-04 19:57:49 +0100
commit1d96f6863e335956838e1002241a018affdaa287 (patch)
treef30f1c8fc29e8a9d0b05d7be921ae3ab576d9f6b /target/linux/mediatek/image/mt7622.mk
parent2bea35cb55d769ab1fdf497baa1c6c3261a33ca4 (diff)
downloadupstream-1d96f6863e335956838e1002241a018affdaa287.tar.gz
upstream-1d96f6863e335956838e1002241a018affdaa287.tar.bz2
upstream-1d96f6863e335956838e1002241a018affdaa287.zip
mediatek: build ubnt-ledbar as a module
The config for LEDS_UBNT_LEDBAR doesn't stay in mt7629 kconfig because of its I2C dependency. Build it as a module and let buildroot handle this config option instead. Signed-off-by: Chuanhong Guo <gch981213@gmail.com> (cherry picked from commit d9ea9c06e98b597174e0e94e0a13934637c0c03e)
Diffstat (limited to 'target/linux/mediatek/image/mt7622.mk')
-rw-r--r--target/linux/mediatek/image/mt7622.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index 8e0126f576..39bc7bc2ea 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -228,7 +228,7 @@ define Device/ubnt_unifi-6-lr
DEVICE_DTS_CONFIG := config@1
DEVICE_DTS := mt7622-ubnt-unifi-6-lr
DEVICE_DTS_DIR := ../dts
- DEVICE_PACKAGES := kmod-mt7915e
+ DEVICE_PACKAGES := kmod-mt7915e kmod-leds-ubnt-ledbar
endef
TARGET_DEVICES += ubnt_unifi-6-lr
@@ -238,7 +238,7 @@ define Device/ubnt_unifi-6-lr-ubootmod
DEVICE_VARIANT := U-Boot mod
DEVICE_DTS := mt7622-ubnt-unifi-6-lr-ubootmod
DEVICE_DTS_DIR := ../dts
- DEVICE_PACKAGES := kmod-mt7915e
+ DEVICE_PACKAGES := kmod-mt7915e kmod-leds-ubnt-ledbar
KERNEL := kernel-bin | lzma
KERNEL_INITRAMFS_SUFFIX := -recovery.itb
KERNEL_INITRAMFS := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb with-initrd | pad-to 64k