aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/mt7622.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2019-08-02 10:33:28 +0200
committerJohn Crispin <john@phrozen.org>2019-08-02 10:36:11 +0200
commit66458c49aa14ebc9ba2e4f9b6a323b8ff122807b (patch)
tree43cd8477d8341136c691d49b139038b14793f635 /target/linux/mediatek/image/mt7622.mk
parentcb49e46a8a4526d86270ced3ba3aa90225ca82d7 (diff)
downloadupstream-66458c49aa14ebc9ba2e4f9b6a323b8ff122807b.tar.gz
upstream-66458c49aa14ebc9ba2e4f9b6a323b8ff122807b.tar.bz2
upstream-66458c49aa14ebc9ba2e4f9b6a323b8ff122807b.zip
mediatek: add v4.19 support
Bump the target to v4.19. Add a patch with additional eth driver fixes/features that MTK provided aswell as the driver for the new mt7530 switch. Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/mediatek/image/mt7622.mk')
-rw-r--r--target/linux/mediatek/image/mt7622.mk23
1 files changed, 20 insertions, 3 deletions
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index 86b25ce33c..1644a3ea68 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -1,9 +1,26 @@
define Device/MTK-RFB1
- DEVICE_TITLE := MTK7622 rfb1 AP
+ DEVICE_TITLE := MTK7622 rfb1 AP
DEVICE_DTS := mt7622-rfb1
DEVICE_DTS_DIR := $(DTS_DIR)/mediatek
- SUPPORTED_DEVICES := mt7622
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb3 \
- kmod-ata-core kmod-ata-ahci-mtk
+ kmod-ata-core kmod-ata-ahci-mtk
endef
TARGET_DEVICES += MTK-RFB1
+
+define Device/MTK-LYNX-RFB1
+ DEVICE_TITLE := MTK7622 Lynx rfb1 AP
+ DEVICE_DTS := mt7622-lynx-rfb1
+ DEVICE_DTS_DIR := $(DTS_DIR)/mediatek
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb3 \
+ kmod-ata-core kmod-ata-ahci-mtk
+endef
+TARGET_DEVICES += MTK-LYNX-RFB1
+
+define Device/BPI-R64
+ DEVICE_TITLE := Bannan Pi R64
+ DEVICE_DTS := mt7622-bananapi-bpi-r64
+ DEVICE_DTS_DIR := $(DTS_DIR)/mediatek
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb3 \
+ kmod-ata-core kmod-ata-ahci-mtk
+endef
+TARGET_DEVICES += BPI-R64