aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/mt7622.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-14 15:38:51 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-26 22:11:48 +0100
commit49d66e0468c14d8a05bd6c33056708d2051437cb (patch)
tree22a677bca7f12a43af7debb9ebb1bc3aba868d9c /target/linux/mediatek/image/mt7622.mk
parent9e0aab44b656be530b7b92ac03588ffc4d4cd1fa (diff)
downloadupstream-49d66e0468c14d8a05bd6c33056708d2051437cb.tar.gz
upstream-49d66e0468c14d8a05bd6c33056708d2051437cb.tar.bz2
upstream-49d66e0468c14d8a05bd6c33056708d2051437cb.zip
mediatek: use consistent naming scheme for device nodes
This harmonizes the device node names (and thus the image names, too) between subtargets of the mediatek target. So far, each subtarget has somewhat used its own naming scheme. Now, we use the vendor_device syntax there, too. Since DTS names have different patterns and the target only contains a few devices, this does not replace DEVICE_DTS by a calculated default value (like for other targets). SUPPORTED_DEVICES is adjusted based on the node rename where necessary, though it looks like for several older devices it was not set up correctly so far. While at it, this also changes the DTS name for u7623-02-emmc-512m to all-lower-case. Cc: John Crispin <john@phrozen.org> Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/mediatek/image/mt7622.mk')
-rw-r--r--target/linux/mediatek/image/mt7622.mk14
1 files changed, 8 insertions, 6 deletions
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index b84a3a6b50..9a5aedc88d 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -1,4 +1,4 @@
-define Device/MTK-RFB1
+define Device/mediatek_mt7622-rfb1
DEVICE_VENDOR := MediaTek
DEVICE_MODEL := MTK7622 rfb1 AP
DEVICE_DTS := mt7622-rfb1
@@ -6,24 +6,26 @@ define Device/MTK-RFB1
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb3 \
kmod-ata-core kmod-ata-ahci-mtk
endef
-TARGET_DEVICES += MTK-RFB1
+TARGET_DEVICES += mediatek_mt7622-rfb1
-define Device/MTK-LYNX-RFB1
+define Device/mediatek_mt7622-lynx-rfb1
DEVICE_VENDOR := MediaTek
DEVICE_MODEL := MTK7622 Lynx rfb1 AP
DEVICE_DTS := mt7622-lynx-rfb1
DEVICE_DTS_DIR := $(DTS_DIR)/mediatek
+ SUPPORTED_DEVICES := mediatek,mt7622-rfb1
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb3 \
kmod-ata-core kmod-ata-ahci-mtk
endef
-TARGET_DEVICES += MTK-LYNX-RFB1
+TARGET_DEVICES += mediatek_mt7622-lynx-rfb1
-define Device/BPI-R64
+define Device/lemaker_bananapi-bpi-r64
DEVICE_VENDOR := LeMaker
DEVICE_MODEL := Banana Pi R64
DEVICE_DTS := mt7622-bananapi-bpi-r64
DEVICE_DTS_DIR := $(DTS_DIR)/mediatek
+ SUPPORTED_DEVICES := bananapi,bpi-r64
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb3 \
kmod-ata-core kmod-ata-ahci-mtk
endef
-TARGET_DEVICES += BPI-R64
+TARGET_DEVICES += lemaker_bananapi-bpi-r64