aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/mt7622.mk
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-05 22:57:29 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-11 19:40:03 +0100
commit228bb84744589efa38ebddd7a75bf97de6789aeb (patch)
tree0b9ed1ececdc0dda9b3c72885897b23cf6332b4f /target/linux/mediatek/image/mt7622.mk
parent95c1fce821c37d5afcd84df92b58c5ae184f8bcd (diff)
downloadupstream-228bb84744589efa38ebddd7a75bf97de6789aeb.tar.gz
upstream-228bb84744589efa38ebddd7a75bf97de6789aeb.tar.bz2
upstream-228bb84744589efa38ebddd7a75bf97de6789aeb.zip
kernel: make kmod-ata-core selected by dependent modulesupstreamless-old-master
Currently kmod-ata-* will not get into images unless kmod-ata-core is added to DEVICE_PACKAGES as well. By changing the dependencies from "depends on" to "select", we do not have the issue anymore. Furthermore, we can remove most occurrences of the package from DEVICE_PACKAGES and similar variables, as it is now pulled by dependent modules such as: - kmod-ata-ahci - kmod-ata-ahci-mtk - kmod-ata-sunxi While at it, use AddDepends/ata for kmod-ata-pdc202xx-old. Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/mediatek/image/mt7622.mk')
-rw-r--r--target/linux/mediatek/image/mt7622.mk6
1 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index 486ab98b0f..0d8af5a9ee 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -3,8 +3,7 @@ define Device/mediatek_mt7622-rfb1
DEVICE_MODEL := MTK7622 rfb1 AP
DEVICE_DTS := mt7622-rfb1
DEVICE_DTS_DIR := $(DTS_DIR)/mediatek
- DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb3 \
- kmod-ata-core kmod-ata-ahci-mtk
+ DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb3 kmod-ata-ahci-mtk
endef
TARGET_DEVICES += mediatek_mt7622-rfb1
@@ -14,7 +13,6 @@ define Device/bpi_bananapi-r64
DEVICE_DTS := mt7622-bananapi-bpi-r64
DEVICE_DTS_DIR := $(DTS_DIR)/mediatek
SUPPORTED_DEVICES := bananapi,bpi-r64
- DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb3 \
- kmod-ata-core kmod-ata-ahci-mtk
+ DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb3 kmod-ata-ahci-mtk
endef
TARGET_DEVICES += bpi_bananapi-r64