aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/filogic.mk
diff options
context:
space:
mode:
authorHank Moretti <mchank9999@gmail.com>2023-07-26 14:39:16 +0000
committerDaniel Golle <daniel@makrotopia.org>2023-08-07 16:31:27 +0100
commit34d8913bd563cfcb24804b24b99473871c886135 (patch)
treefdfbf6f8566fee3bf9853ce2ea34934ca57d61db /target/linux/mediatek/image/filogic.mk
parent0f0ea1087b4c42a9fcdd5f003fef62cf587da40b (diff)
downloadupstream-34d8913bd563cfcb24804b24b99473871c886135.tar.gz
upstream-34d8913bd563cfcb24804b24b99473871c886135.tar.bz2
upstream-34d8913bd563cfcb24804b24b99473871c886135.zip
mediatek: filogic: add specific layout for WR30U
Because this device enable NMBM by default, most users use custom U-Boot with NMBM-Enabled in Chinese forums. This layout is the same as the ubootmod layout but enabling NMBM. Signed-off-by: Hank Moretti <mchank9999@gmail.com>
Diffstat (limited to 'target/linux/mediatek/image/filogic.mk')
-rw-r--r--target/linux/mediatek/image/filogic.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/mediatek/image/filogic.mk b/target/linux/mediatek/image/filogic.mk
index 12085efbd4..e008c23c0a 100644
--- a/target/linux/mediatek/image/filogic.mk
+++ b/target/linux/mediatek/image/filogic.mk
@@ -380,6 +380,23 @@ define Device/tplink_tl-xdr6088
endef
TARGET_DEVICES += tplink_tl-xdr6088
+define Device/xiaomi_mi-router-wr30u-112m-nmbm
+ DEVICE_VENDOR := Xiaomi
+ DEVICE_MODEL := Mi Router WR30U (112M UBI with NMBM-Enabled layout)
+ DEVICE_DTS := mt7981b-xiaomi-mi-router-wr30u-112m-nmbm
+ DEVICE_DTS_DIR := ../dts
+ UBINIZE_OPTS := -E 5
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ DEVICE_PACKAGES := kmod-mt7981-firmware mt7981-wo-firmware
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+ ARTIFACTS := initramfs-factory.ubi
+ ARTIFACT/initramfs-factory.ubi := append-image-stage initramfs-kernel.bin | ubinize-kernel
+endif
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+endef
+TARGET_DEVICES += xiaomi_mi-router-wr30u-112m-nmbm
+
define Device/xiaomi_mi-router-wr30u-stock
DEVICE_VENDOR := Xiaomi
DEVICE_MODEL := Mi Router WR30U (stock layout)