aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-08-20 21:11:32 +0100
committerDaniel Golle <daniel@makrotopia.org>2022-01-23 20:20:37 +0000
commit1ee75dd2906e15f874220151cdd4802d50e4a082 (patch)
tree9c9fb99a31fe6efd9d2a79fd10d34a14c186fa1f /target/linux/mediatek/image/Makefile
parent213b406ae3364913ef73ea027a38605107fcf78d (diff)
downloadupstream-1ee75dd2906e15f874220151cdd4802d50e4a082.tar.gz
upstream-1ee75dd2906e15f874220151cdd4802d50e4a082.tar.bz2
upstream-1ee75dd2906e15f874220151cdd4802d50e4a082.zip
mediatek: mt7623: rework images for U7623-02 board
Users of older OpenWrt versions need sysupgrade using the *emmc.img.gz file once which will upgrade U-Boot and switch to the new image layout. Users of the vendor firmware need to first flash the legacy image to then sunsequently carry out a full-flash upgrade. Alternatively the board can also be flashed using MediaTek's proprietary SP Flash Tool. Configuration as well as persistent MAC address will be lost once at this point and you will have to redo (or restore) all configuration manually. To restore the previous persistent MAC address users may set it manually using fw_setenv ethaddr 00:11:22:33:44:55 For future upgrades once running OpenWrt past this commit, the usual *sysupgrade.itb file can be used. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/mediatek/image/Makefile')
-rw-r--r--target/linux/mediatek/image/Makefile12
1 files changed, 1 insertions, 11 deletions
diff --git a/target/linux/mediatek/image/Makefile b/target/linux/mediatek/image/Makefile
index 7aa7a7285c..4c17e5845a 100644
--- a/target/linux/mediatek/image/Makefile
+++ b/target/linux/mediatek/image/Makefile
@@ -6,17 +6,7 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-define Build/sysupgrade-emmc
- rm -f $@.recovery
- mkfs.fat -C $@.recovery 3070
-
- ./gen_$(SUBTARGET)_emmc_img.sh $@ \
- $(IMAGE_KERNEL) \
- $@.recovery \
- $(IMAGE_ROOTFS)
-endef
-
-# default all platform image(fit) build
+# default all platform image(fit) build
define Device/Default
PROFILES = Default $$(DEVICE_NAME)
KERNEL_NAME := Image