aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-07-17 14:40:04 +0200
committerJo-Philipp Wich <jo@mein.io>2018-07-17 14:40:04 +0200
commit8194f9ef4a5ab4587e8f6cf1aec96ba89c5766fd (patch)
treec3a2c4620d9edac333275d71f2bf6362aebc89fe /target/linux/mediatek/image/Makefile
parent1bad852ff597fd0535e02703f0c4b83447aaff45 (diff)
downloadupstream-8194f9ef4a5ab4587e8f6cf1aec96ba89c5766fd.tar.gz
upstream-8194f9ef4a5ab4587e8f6cf1aec96ba89c5766fd.tar.bz2
upstream-8194f9ef4a5ab4587e8f6cf1aec96ba89c5766fd.zip
mediatek: fix parallel build issues in image build code
Drop the parallel-unsafe custom Build/dtb macro and use the .dtb artifacts produced by the generic image build code. Also remove unused .dtb references in the mt7623 subtarget. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/linux/mediatek/image/Makefile')
-rw-r--r--target/linux/mediatek/image/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/target/linux/mediatek/image/Makefile b/target/linux/mediatek/image/Makefile
index 5e2b2c6d0a..d14c12ee7c 100644
--- a/target/linux/mediatek/image/Makefile
+++ b/target/linux/mediatek/image/Makefile
@@ -16,12 +16,6 @@ ifeq ($(SUBTARGET),mt7622)
KERNEL_LOADADDR = 0x41080000
endif
-# build dtb
-define Build/dtb
- $(call Image/BuildDTB,$(DEVICE_DTS_DIR)/$(DEVICE_DTS).dts,$(DEVICE_DTS_DIR)/$(DEVICE_DTS).dtb)
- $(CP) $(DEVICE_DTS_DIR)/$(DEVICE_DTS).dtb $(BIN_DIR)/
-endef
-
define Build/sysupgrade-emmc
rm -f $@.recovery
mkfs.fat -C $@.recovery 3070
@@ -42,13 +36,13 @@ define Device/Default
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
ifeq ($(SUBTARGET),mt7623)
KERNEL_NAME := zImage
- KERNEL := dtb | kernel-bin | append-dtb | uImage none
- KERNEL_INITRAMFS := dtb | kernel-bin | append-dtb | uImage none
+ KERNEL := kernel-bin | append-dtb | uImage none
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | uImage none
endif
ifeq ($(SUBTARGET),mt7622)
KERNEL_NAME := Image
- KERNEL = dtb | kernel-bin | lzma | fit lzma $$(DEVICE_DTS_DIR)/$$(DEVICE_DTS).dtb
- KERNEL_INITRAMFS = dtb | kernel-bin | lzma | fit lzma $$(DEVICE_DTS_DIR)/$$(DEVICE_DTS).dtb
+ KERNEL = kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+ KERNEL_INITRAMFS = kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
endif
endef