aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/Makefile
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2019-11-01 11:17:28 +0800
committerChuanhong Guo <gch981213@gmail.com>2019-11-04 20:51:19 +0800
commit09fe0c847dd32a829fd3dcb21e284cc0c7a3e763 (patch)
tree54cf3c29b96e19d1754732b45b7b3160bb8f8285 /target/linux/mediatek/image/Makefile
parent58b0d3ecd66ef220101d1f4dfe550242d6004fce (diff)
downloadupstream-09fe0c847dd32a829fd3dcb21e284cc0c7a3e763.tar.gz
upstream-09fe0c847dd32a829fd3dcb21e284cc0c7a3e763.tar.bz2
upstream-09fe0c847dd32a829fd3dcb21e284cc0c7a3e763.zip
mediatek: add mt7629 subtarget with rfb image
base-files are added into subtarget directory like what's done recently in ath79. For this subtarget, metadata checks are enforced and a SUPPORTED_DEVICE is added to generate proper metadata. Since we only have mt7629 support in 4.19, override KERNEL_PATCHVER in target.mk for now. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/mediatek/image/Makefile')
-rw-r--r--target/linux/mediatek/image/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/target/linux/mediatek/image/Makefile b/target/linux/mediatek/image/Makefile
index d14c12ee7c..ddf4e435c7 100644
--- a/target/linux/mediatek/image/Makefile
+++ b/target/linux/mediatek/image/Makefile
@@ -16,6 +16,10 @@ ifeq ($(SUBTARGET),mt7622)
KERNEL_LOADADDR = 0x41080000
endif
+ifeq ($(SUBTARGET),mt7629)
+KERNEL_LOADADDR = 0x40008000
+endif
+
define Build/sysupgrade-emmc
rm -f $@.recovery
mkfs.fat -C $@.recovery 3070
@@ -33,13 +37,13 @@ define Device/Default
FILESYSTEMS := squashfs
DEVICE_DTS_DIR := $(DTS_DIR)
IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+ SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
ifeq ($(SUBTARGET),mt7623)
KERNEL_NAME := zImage
KERNEL := kernel-bin | append-dtb | uImage none
KERNEL_INITRAMFS := kernel-bin | append-dtb | uImage none
-endif
-ifeq ($(SUBTARGET),mt7622)
+else
KERNEL_NAME := Image
KERNEL = kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
KERNEL_INITRAMFS = kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
@@ -54,6 +58,10 @@ ifeq ($(SUBTARGET),mt7623)
include mt7623.mk
endif
+ifeq ($(SUBTARGET),mt7629)
+include mt7629.mk
+endif
+
define Image/Build
$(call Image/Build/$(1),$(1))
endef